Calling Developers!
We are reenergizing our code contribution process! Learn More

How to ignore requests to backend-api and backend-gateway?

Options
simo.savonen
simo.savonen Spryker Solution Partner Posts: 8 🧑🏻‍🚀 - Cadet

We are getting a daily Newrelic alarm about requests to backend-api and backend-gateway, how "no route was found…".

Newrelic sees them as APM errors. Do you have any suggestions how to filter these out? The requests seem like bots trying to find a weakness, some requests are asking for the WordPress login page from these URLs.

Answers

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 ⚖️ - Guardians (admin)
    Options

    Heyhey @simo.savonen ,

    sadly I do not have an answer to your question, yet I am interested to understand why external bots can trigger backend-gateway 404 exceptions? O.o Shouldnt this be inside a private network? (this is how I understood it at least).

    All the best,

    Florian

  • simo.savonen
    simo.savonen Spryker Solution Partner Posts: 8 🧑🏻‍🚀 - Cadet
    edited April 5
    Options

    Still trying to solve this issue, support was unable to offer a solution, other than to increase the limit before an alert is sent. This would make other APM errors not trigger an alarm. We only need to get rid of these errors created by bot visits.

    Is it possible to ignore Symfony\Component\HttpKernel\Exception\NotFoundHttpException so that it's never sent to NewRelic? As I've not been able to find a way to filter these errors in the NewRelic dashboard.

    Would adding a setting in $config[MonitoringConstants::IGNORABLE_TRANSACTIONS] work? How to find the correct setting, what is the transaction called?