Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello, I am supposed to start the foundations workshop today but I have not been able to restart th

Options
U01S704QALU
U01S704QALU Posts: 7 🧑🏻‍🚀 - Cadet
edited March 2021 in Vagrant

Hello,

I am supposed to start the foundations workshop today but I have not been able to restart the demo shop on my mac. I have tried and tried. I followed the read me to the letter but it just seems like it never works. It's a little frustrating. It worked at some point in the past but does not work now.

VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY="<https://github.com/spryker-shop/b2c-demo-shop.git>" vagrant up

After running that, I am basically stuck as the command stops here:

DEBUG ssh: Re-using SSH connection.
 INFO ssh: Execute: echo; printf $SSH_AUTH_SOCK (sudo=false)
DEBUG ssh: stderr: mesg: ttyname failed: Inappropriate ioctl for device

DEBUG ssh: stderr: 41e57d38-b4f7-4e46-9c38-13873d338b86-vagrant-ssh
DEBUG ssh: Exit status: 0
 INFO ssh: Setting SSH_AUTH_SOCK remotely: /tmp/ssh-SoqrItgi0Z/agent.1571
DEBUG ssh: stderr: 41e57d38-b4f7-4e46-9c38-13873d338b86-vagrant-ssh
DEBUG ssh: Sending SSH keep-alive...
DEBUG ssh: Sending SSH keep-alive...
DEBUG ssh: Sending SSH keep-alive...
DEBUG ssh: Sending SSH keep-alive...
DEBUG ssh: Sending SSH keep-alive...

It keeps returning the this for a long time now. Does not get past there. Any help would be appreciated

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Have never seen something like this in the past so no clue but the universal suggestion would be to try to vagrant destroy and try to re-install once again from scratch.

    Btw, if it's an existing devvm, you just need to run vagrant up.

    VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY="<https://github.com/spryker-shop/b2c-demo-shop.git>" vagrant up is used only during the installation phase.

  • U01S704QALU
    U01S704QALU Posts: 7 🧑🏻‍🚀 - Cadet
    Options

    The solution was vagrant reload btw