Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello, Having problems with Spryker installation, can someone help me with this error.

Options
UPWG882P6
UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet

Hello, Having problems with Spryker installation, can someone help me with this error.

«1

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited September 2020
    Options

    Hi! Seems like there is a mismatch between ES version and spryker/elastica module.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    edited September 2020
    Options

    Nice, Thanks for your time, How to resolve this?

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited September 2020
    Options

    Please describe what are you trying to do.
    Install some project, started earlier (not latest demo shop), with latest docker-sdk?

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    Am trying to install spryker project on my system, following the steps from the installation document.

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Thanks!
    Try to run COMPOSER_MEMORY_LIMIT=-1 composer require "ruflin/elastica:6.*" "spryker/elastica:5.*" --update-with-dependencies --optimize-autoloader --ignore-platform-reqs and then try to install once again.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    on vendor/bin/install encountered this error.

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Maybe you will need to increase memory limit for vagrant by editing .vm file.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    you mean to run this ,ulimit -n 65535 ?

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    just did it, updating the dependencies.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    PHP Fatal error: Allowed memory size of 2147483648 bytes exhausted (tried to allocate 67108864 bytes) in phar:///usr/local/bin/composer/src/Composer/DependencyResolver/Pool.php on line 339

    Fatal error: Allowed memory size of 2147483648 bytes exhausted (tried to allocate 67108864 bytes) in phar:///usr/local/bin/composer/src/Composer/DependencyResolver/Pool.php on line 339

    Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.%

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    currently , its 3200, doubling will do?

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    how much do u suggest?

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Doubling will do.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    cool

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    memory allocation error

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    steps done: vagrant halt,

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    vagrant up

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    vagrant ssh

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    composer install

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    vendor/bin/install

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited September 2020
    Options

    From the state of the initial error you would need to do:
    1. vagrant halt
    2. edit .vm to set memory to 6400
    3. vagrant up
    4. vagrant ssh
    5. COMPOSER_MEMORY_LIMIT=-1 composer require "ruflin/elastica:6.*" "spryker/elastica:5.*" --update-with-dependencies --optimize-autoloader --ignore-platform-reqs
    6. vendor/bin/install or just install

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    I don't get why have you got the initial error in the first place. Are you sure you are trying to install spryker-shop/b2c-demo-shop and not spryker-shop/suite?

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    edited September 2020
    Options

    $VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY=“https://github.com/spryker-shop/b2c-demo-shop.git
    $ /Volumes/IntgrmSprykrEtrib/devvm  vagrant up
    Bringing machine ‘default’ up with ‘virtualbox’ provider...
    ==> default: Box ‘devvm3.1.0’ could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
    ==> default: Box file was not detected as metadata. Adding it directly...
    ==> default: Adding box ‘devvm3.1.0’ (v0) for provider: virtualbox
    default: Downloading: https://github.com/spryker/devvm/releases/download/v3.1.0/spryker-devvm.box
    ==> default: Box download is resuming from prior download progress
    ==> default: Successfully added box ‘devvm3.1.0’ (v0) for ‘virtualbox’!
    The following settings will be used for the new VM:
    VM_PROJECT = ‘suite’
    VM_IP = ‘10.10.0.226’
    VM_MEMORY = ‘3200’
    VM_CPUS = ‘4’
    VM_NAME = ‘Spryker Dev VM (suite)’
    VM_DOMAIN = ‘suite’
    VM_SKIP_SF = ‘0’
    VM_IS_WINDOWS = ‘0’
    SPRYKER_BRANCH = ‘master’
    SPRYKER_REPOSITORY = ‘https://github.com/spryker-shop/suite.git

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    I deleted the previous repo and started reInstalling, this is what i found, though am giving b2c-demo-shop.git repo, its always taking suit.git repo .

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    Do you think. this might be the problem ? if so, have any idea why is happening?

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    So it's suite in the end.
    Our latest devvm is aimed to work with b2b\b2c demo shops, not with suite.
    Suite is already ahead and is using ES7.
    Where b2b\b2c demo shops are still on ES6. And devvm contains only ES6.
    So trying to install suite in the devvm will lead you to an initial error.

    From what you've posted I can conclude that you are running VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY=“<https://github.com/spryker-shop/b2c-demo-shop.git>” first and then separately vagrant up. This should be one command.

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    with one command am encountering the error, so i tried to split it, here is the error,

  • UPWG882P6
    UPWG882P6 Posts: 140 🧑🏻‍🚀 - Cadet
    Options

    $VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY=“https://github.com/spryker-shop/b2c-demo-shop.git” vagrant up
    Bringing machine ‘default’ up with ‘virtualbox’ provider...
    ==> default: Box ‘devvm3.1.0’ could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
    ==> default: Box file was not detected as metadata. Adding it directly...
    ==> default: Adding box ‘devvm3.1.0’ (v0) for provider: virtualbox
    default: Downloading: https://github.com/spryker/devvm/releases/download/v3.1.0/spryker-devvm.box
    ==> default: Box download is resuming from prior download progress
    An error occurred while downloading the remote file. The error
    message, if any, is reproduced below. Please fix this error and try
    again.

    OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 54

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited September 2020
    Options

    There is an issue thread for vagrant about the same - https://github.com/hashicorp/vagrant/issues/10007. But there is no final solution. Seems more like internet connection problems.

    I would recommend to remove existing vagrant machines from virtual box, remove the current directory you are working with and to try once again.