Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi All, Facing this issue while setting up new b2b shop application, Any suggestions on this?

Options
U03D5K35WP3
U03D5K35WP3 Posts: 11 🧑🏻‍🚀 - Cadet

Hi All,
Facing this issue while setting up new b2b shop application, Any suggestions on this?

Comments

  • U03D5K35WP3
    U03D5K35WP3 Posts: 11 🧑🏻‍🚀 - Cadet
    Options

    I have tried to update the module using the given command "composer update spryker/code-it-now" but still getting the same error by running this command.

  • Bruno Zamorano
    Bruno Zamorano Support & Cloud Operations @Spryker Sprykee Posts: 36 🧑🏻‍🚀 - Cadet
    Options

    Since you're setting up from scratch: have you tried prune docker and start again and update module spryker/code-it-now?

  • USWNH3UHJ
    USWNH3UHJ Posts: 23 🧑🏻‍🚀 - Cadet
    Options

    @UQY5C74F4 so im facing with the same problem and docker system prune and docker/sdk cli composer update spryker/code-it-now does not work. What’s other possibilites to fix it?

  • domagoj.krizanec
    domagoj.krizanec Spryker Technology Partner Posts: 9 🧑🏻‍🚀 - Cadet
    Options

    Hi. This is a bit hacky fix, but worked for me. So first update your deploy.*.yml file to use image with php 7.4.20 (tag: spryker/php:7.4-alpine3.12). Now in your composer.json file set package "spryker/code-it-now" to use version 1.0.1 ("spryker/code-it-now": "1.0.1",) and set your php version to be at 7.4.20 ("php": "7.4.20"). Now, in your composer.lock file completely remove this codeitnowin/barcode package (as shown in image), update "spryker/code-it-now" package to use new version and reference:

     {
                "name": "spryker/code-it-now",
                "version": "1.0.1",
                "source": {
                    "type": "git",
                    "url": "<https://github.com/spryker/code-it-now.git>",
                    "reference": "5b640c417967df863f1537c1336e19d50c0df3c9"
                },
                "dist": {
                    "type": "zip",
                    "url": "<https://api.github.com/repos/spryker/code-it-now/zipball/5b640c417967df863f1537c1336e19d50c0df3c9>",
                    "reference": "5b640c417967df863f1537c1336e19d50c0df3c9",
                    "shasum": ""
                },
                "require": {
                    "php": ">=7.4",
                    "spryker/barcode-extension": "^1.0.0"
                },
                "require-dev": {
        @@ -16352,7 +16326,10 @@
                    "proprietary"
                ],
                "description": "CodeItNow module",
                "support": {
                    "source": "<https://github.com/spryker/code-it-now/tree/1.0.1>"
                },
                "time": "2022-04-21T13:32:43+00:00"
            },
    

    And in the end of the file, again increase php version to 7.4.20.
    After that just run docker/sdk up again and it should pass.

  • U03D5K35WP3
    U03D5K35WP3 Posts: 11 🧑🏻‍🚀 - Cadet
    Options

    Thanks @UU416RABB this works for mw also.