Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi I have a question about arm64 docker compatibility for M1 macs. I guess this is a bleeding edge t

Options
UKEP86J66
UKEP86J66 Posts: 208 πŸ§‘πŸ»β€πŸš€ - Cadet

Hi I have a question about arm64 docker compatibility for M1 macs. I guess this is a bleeding edge topic and milage may vary πŸ™‚
We have our own Spryker docker solution which we are adapting for M1 macs and have hit a problem with node-sass for the Zed asset building. Apparently there are no prebuilt arm64 bindings (https://github.com/sass/node-sass/releases) and it is not possible to switch to another version of sass due to coupling via orxy-for-zed
I see there is experimental work on the Spryker DockerSDK (https://github.com/spryker/docker-sdk/pull/225) for M1 but do not see any changes for node or sass so wondering if anyone has any insights on how this is working for others?

Comments

  • U028TJGK6Q4
    U028TJGK6Q4 Posts: 10 πŸ§‘πŸ»β€πŸš€ - Cadet
    edited December 2021
    Options

    I always run in Out of Memory error during composer installation with this experimental branch.

    But I heard for some people it works fine

  • UKEP86J66
    UKEP86J66 Posts: 208 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    That is not something I would expect, but guess that is why this PR is experimental πŸ§ͺ

  • U013M1LC46A
    U013M1LC46A Posts: 23 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    @U028TJGK6Q4 Memory leaks are a general issue with the m1, it’s basically something that apple needs to fix (hopefully soon). I’ve only used the M1 for a few days, so prolly didn’t have the chance to encounter any memory issues just yet.
    While spryker does work on the M1, it’s unfortunately slower than my old intel MacBook. With M1 Max + 32gb I’m seeing stuff like 5-10s TTFB on catalog page and 16 MINUTES to do yves frontend build.
    In general anything that touches a lot of files on the containers is multiple times slower than on my old intel.
    Fingers crossed that more improvements will be introduced to that experimental branch cuz right now it’s not looking too good.

  • U013M1LC46A
    U013M1LC46A Posts: 23 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    @UKEP86J66 Just tried doing console frontend:zed:build and got a similar error (plus many others).

  • UKEP86J66
    UKEP86J66 Posts: 208 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    😞 fingers crossed that we will see progress soon.

  • U028TJGK6Q4
    U028TJGK6Q4 Posts: 10 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Maybe you could finish the installation because you have 32gb. No chance with my 16gb model. Anyway developing with this kind of performance is not possible with M1 right now.

    According to this comment official support is planned for Q4. Not sure if the experimental branch is related to this.
    https://github.com/spryker/docker-sdk/issues/192#issuecomment-950894157

  • U013M1LC46A
    U013M1LC46A Posts: 23 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    I know that some people managed to get it installed on a 16gb 13" M1, but a workaround was needed: Modify line 17 ofΒ *docker/bin/sdk/runtime/wait.sh*Β so that the command does not exit when the wait time is over
    So instead of && exit 1 is should be && break . Maybe that can be of help?
    And you can always go for 32gb instead of 16gb. 16gb is really not enough for a proper spryker dev machine these days, regardless if it’s M1 or not….

  • U028TJGK6Q4
    U028TJGK6Q4 Posts: 10 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    That workaround sadly does not help, still receiving this error

  • U028TJGK6Q4
    U028TJGK6Q4 Posts: 10 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    But I would not say 16GB is not enough. I am developing with a Windows Desktop which also has 16GB and it works like a charm...

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 βš–οΈ - Guardians (admin)
    edited December 2021
    Options

    Heyhey, the comment with the Q4 is still valid and the goal. But I can not tell you any release-date yet :crossed_fingers:

  • UPDQFGGM9
    UPDQFGGM9 Posts: 29 πŸ§‘πŸ»β€πŸš€ - Cadet
    edited December 2021
    Options

    I’m not running into issues on an M1 but I’m facing different issues, for example the old node-gyp version which is brought in by node-sass . Since node-sass is depcrecated and node-gyp is 5 versions behind. Are there any plans to drop support for this?
    Do we have a work-around to build zed without oryx for zed?

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 βš–οΈ - Guardians (admin)
    Options

    Heyhey, just a small update: it was not finished Q4, current goal is Q1 😒