Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

spryker/testify is by composer definition OK with codeception 5, but if both are installed you will

Options
U0251S9J5LP
U0251S9J5LP Posts: 22 🧑🏻‍🚀 - Cadet
edited October 2022 in Slack General

spryker/testify is by composer definition OK with codeception 5, but if both are installed you will get:
Fatal error: Trait "Codeception\Command\Shared\Config" not found in /data/vendor/spryker/testify/tests/SprykerTest/Shared/Testify/_support/Fixtures/FixturesCommand.php on line 21
@spryker are you aware of that?

    "name": "spryker/testify",
    "type": "library",
    "description": "Testify module",
    "license": "proprietary",
    "require": {
    "codeception/codeception": "^3.6.1 || ^4.0.0 || ^5.0.0",

Comments

  • U0251S9J5LP
    U0251S9J5LP Posts: 22 🧑🏻‍🚀 - Cadet
    Options

    also

    Fatal error: Type of SprykerTest\Shared\Testify\Helper\Environment::$config must be array (as in class Codeception\Module) in /data/vendor/spryker/testify/tests/SprykerTest/Shared/Testify/_support/Helper/Environment.php on line 0
    [18-Oct-2022 10:33:31 UTC] PHP Fatal error:  Type of SprykerTest\Shared\Testify\Helper\Environment::$config must be array (as in class Codeception\Module) in /data/vendor/spryker/testify/tests/SprykerTest/Shared/Testify/_support/Helper/Environment.php on line 0
    
  • U0251S9J5LP
    U0251S9J5LP Posts: 22 🧑🏻‍🚀 - Cadet
    Options

    and

    Fatal error: Declaration of Codeception\Module::getModule(string $name): Codeception\Module must be compatible with SprykerTest\Shared\Testify\Helper\FactoryHelperTrait::getModule($name) in /data/vendor/spryker/testify/tests/SprykerTest/Shared/Testify/_support/Helper/DependencyHelper.php on line 287
    [18-Oct-2022 10:34:45 UTC] PHP Fatal error:  Declaration of Codeception\Module::getModule(string $name): Codeception\Module must be compatible with SprykerTest\Shared\Testify\Helper\FactoryHelperTrait::getModule($name) in /data/vendor/spryker/testify/tests/SprykerTest/Shared/Testify/_support/Helper/DependencyHelper.php on line 287
    
  • U0251S9J5LP
    U0251S9J5LP Posts: 22 🧑🏻‍🚀 - Cadet
    Options

    i doubt it ever has been tested with codeception 5

  • Please see https://github.com/spryker/testify/releases/tag/3.46.1
    It was an oversight to release v5 range, as it is not compatible yet

    There are open PRs for this to address this soon.