Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello all, my project is set up with wsl2,docker on windows. I am having difficulties to setup xdebu

Options
U023N0ZGN2F
U023N0ZGN2F Posts: 8 🧑🏻‍🚀 - Cadet

Hello all, my project is set up with wsl2,docker on windows. I am having difficulties to setup xdebug in phpstorm. can someone help wih this?

Comments

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    edited July 2021
    Options

    maybe I can help
    can you show your debug config file?
    this will contain by default

    xdebug.remote_host=${SPRYKER_XDEBUG_HOST_IP}
    

    and

    xdebug.client_host=${SPRYKER_XDEBUG_HOST_IP}
    

    Can you also show your debug config in storm

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    sorry, was busy until now

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    replace “${SPRYKER_XDEBUG_HOST_IP}” with “host.docker.internal”
    (beware the first part is different in each row)

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    follow this https://documentation.spryker.com/docs/configuring-debugging-in-docker manual
    do NOT set the ide key in the config file, this will stock the debugger working when you do console calls

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    if you have the debug settings and server settings also like in the manual then editing the config file like I said above should do the trick

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    make sure you started the container with -x

  • U023N0ZGN2F
    U023N0ZGN2F Posts: 8 🧑🏻‍🚀 - Cadet
    Options

    Hi Nathalie, good morning. I tried this solution but unfortunately it is not working. i also tried changing host manually. but still its same. can it be some other reason? I also followed the manual.

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    try to bootstrap the container after changing the debug config

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    (docker/sdk boot)

  • U023N0ZGN2F
    U023N0ZGN2F Posts: 8 🧑🏻‍🚀 - Cadet
    Options

    ok

  • U023N0ZGN2F
    U023N0ZGN2F Posts: 8 🧑🏻‍🚀 - Cadet
    Options

    hey Nathalie. thanks a ton. its working now. 🙂

  • U01LLUGR1F0
    U01LLUGR1F0 Posts: 60 🧑🏻‍🚀 - Cadet
    Options

    yeay ❤