Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

can someone explain why is `vendor/bin/console -vvv frontend:install:package-manager` requiring roo

Options
UK5DS29L2
UK5DS29L2 Posts: 546 🧑🏻‍🚀 - Cadet

can someone explain why is vendor/bin/console -vvv frontend:install:package-manager requiring root privileges?

        $process = $this->getProcess('sudo -i apt-get install -y nodejs');

Comments

  • UKHD8KTMF
    UKHD8KTMF Posts: 393 🧑🏻‍🚀 - Cadet
    Options

    if you are installing a system package you need su permissions

  • UK5DS29L2
    UK5DS29L2 Posts: 546 🧑🏻‍🚀 - Cadet
    Options

    well, my guess they didn't know it ?
    https://github.com/nvm-sh/nvm

  • UKHD8KTMF
    UKHD8KTMF Posts: 393 🧑🏻‍🚀 - Cadet
    Options

    it is installing linux system package using apt-get - that is why

  • UKHD8KTMF
    UKHD8KTMF Posts: 393 🧑🏻‍🚀 - Cadet
    Options

    just run apt-get install <> and it will ask for superuser permission

  • UKHD8KTMF
    UKHD8KTMF Posts: 393 🧑🏻‍🚀 - Cadet
    Options

    i.e. apt-get install nodejs

  • UK5DS29L2
    UK5DS29L2 Posts: 546 🧑🏻‍🚀 - Cadet
    Options

    damijanc, I'm asking why is webapp requiring root privileges, not how do I install a package 🙂

  • UK5DS29L2
    UK5DS29L2 Posts: 546 🧑🏻‍🚀 - Cadet
    Options

    https://documentation.spryker.com/docs/system-requirements
    says nothing about debian, and this won't work at all on things like centos where yum is used.
    Not even the Ubuntu 18.04 LTS will work, because node 10.14 is there aliased with nodejs when the docs say 8.11.4
    and
    \Spryker\Zed\SetupFrontend\Business\Model\PackageManager\NodeInstaller::getDownloadCommand
    downloads 8.x

  • Denis Turkov
    Denis Turkov VP Architecture Sprykee Posts: 40 🏛 - Council (mod)
    Options

    @UN6T8SEM7 please have a look.