Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

hi everyone, I got this on my linux, it's timeout issue, does any one have any idea how to fix it? `

Options
U01C1TABT0V
U01C1TABT0V Posts: 61 🧑🏻‍🚀 - Cadet

hi everyone, I got this on my linux, it's timeout issue, does any one have any idea how to fix it?

$ sudo docker logs spryker_b2c_dev_yves_eu_1
2020-10-15 15:14:59,191 INFO Set uid to user 0 succeeded
2020-10-15 15:14:59,201 INFO supervisord started with pid 1
2020-10-15 15:15:00,207 INFO spawned: 'php-fpm_00' with pid 7
2020-10-15 15:15:00,210 INFO spawned: 'php-fpm-debug_00' with pid 8
[15-Oct-2020 15:15:00] NOTICE: fpm is running, pid 7
[15-Oct-2020 15:15:00] NOTICE: ready to handle connections
[15-Oct-2020 15:15:00] NOTICE: fpm is running, pid 8
[15-Oct-2020 15:15:00] NOTICE: ready to handle connections
2020-10-15 15:15:01,322 INFO success: php-fpm_00 entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2020-10-15 15:15:01,323 INFO success: php-fpm-debug_00 entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
[15-Oct-2020 15:33:00] WARNING: [pool worker] child 10, script '/data/public/Yves/index.php' (request: "GET /index.php") execution timed out (66.577890 sec), terminating
[15-Oct-2020 15:33:00] WARNING: [pool worker] child 10 exited on signal 15 (SIGTERM) after 1080.061743 seconds from start
[15-Oct-2020 15:33:00] NOTICE: [pool worker] child 13 started
[15-Oct-2020 15:34:40] WARNING: [pool worker] child 9, script '/data/public/Yves/index.php' (request: "GET /index.php") execution timed out (71.682236 sec), terminating
[15-Oct-2020 15:34:40] WARNING: [pool worker] child 9 exited on signal 15 (SIGTERM) after 1180.075033 seconds from start
[15-Oct-2020 15:34:40] NOTICE: [pool worker] child 14 started

Comments

  • maybe @ULYHPR789 still here?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    It is just very slow so the page cannot be processed. Or stuck somewhere in the middle of PHP script.
    And that is a Linux OS so it is not a file sharing issue.

    It is something not common. I’ve not heard about such behavior especially on Linux.

    I would propose to dump something into a file in index.php and in other places like the controller.

  • Andriy Netseplyayev
    Andriy Netseplyayev Domain Lead Solution Architecture Sprykee Posts: 519 🧑🏻‍🚀 - Cadet
    Options

    just a wild guess, based on

    INFO success: php-fpm-debug_00 entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)

    can that be that you’ve turned on the debugging mode and it’s being stuck on the breakpoint?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    edited October 2020
    Options

    Yep. It is possible if the env in a debug mode.

  • U01C1TABT0V
    U01C1TABT0V Posts: 61 🧑🏻‍🚀 - Cadet
    Options

    I don't think I run it with xdebug, it was just docker/sdk up (without -x)

  • U01C1TABT0V
    U01C1TABT0V Posts: 61 🧑🏻‍🚀 - Cadet
    Options
  • Andriy Netseplyayev
    Andriy Netseplyayev Domain Lead Solution Architecture Sprykee Posts: 519 🧑🏻‍🚀 - Cadet
    Options

    You don’t have to have that option explicitly to start a debugging process. Docker/sdk determines if you’re debugging by the cookie in your request

  • U01C1TABT0V
    U01C1TABT0V Posts: 61 🧑🏻‍🚀 - Cadet
    Options

    i see, what i meant is I didn't have xdebug running, so not sure what causes timeout error, everything i've done comes from the latest DOC https://documentation.spryker.com/docs/installation-guide-development-mode

  • I can confirm. Setup is pretty vanilla. Even the OS. But there were other things that took usually long, like phpstorm indexing. Any idea what could cause that on OS level?