What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Team, My local spryker setup glue API always returns 4

U03KHDBS1CN
U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet
edited June 2022 in Slack General

Team, My local spryker setup glue API http://glue.de.spryker.local/access-tokens always returns 401 for verified customers, any help would be greatly appreciated.

Comments

  • Bruno Zamorano
    Bruno Zamorano Support & Cloud Operations @Spryker Sprykee Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    Hi Jai, have you already Auth on your local Glue?

  • Bruno Zamorano
    Bruno Zamorano Support & Cloud Operations @Spryker Sprykee Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet
    edited June 2022

    on the body of the post http://glue.de.spryker.local/access-tokens you need to add the attributes of your verified customers:

    {
        "attributes": {
          "username": "<mailto:[email protected]|[email protected]>",
          "password": "test"
       }
    }
    
  • U03KHDBS1CN
    U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    Yes I am able to login in my local yves but not on glue API ... my request body is below

  • U03KHDBS1CN
    U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    {
    "data": {
    "type": "access-tokens",
    "attributes": {
    "username": "<mailto:[email protected]|[email protected]>",
    "password": "Test@123"

    }
    

    }
    }

  • Bruno Zamorano
    Bruno Zamorano Support & Cloud Operations @Spryker Sprykee Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    that is body that should work to Auth. Please use an user with the permissions necessary like the example user created in demo-shops sonia:


  • U03KHDBS1CN
    U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    same for the demo shop user as well

  • U03KHDBS1CN
    U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    am running in development mode... is there any changes to be made from code base?

  • U03KHDBS1CN
    U03KHDBS1CN Posts: 36 πŸ§‘πŸ»β€πŸš€ - Cadet

    This works fine on demo mode installation