Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, it seems for the latest required

Options
UK7KBE2JW
UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet

Hi, it seems for https://github.com/spryker/oms/blob/11.16.1/composer.json#L15 the latest required propel version is "spryker/propel": "^3.28.0" since commitIdentical is used https://github.com/spryker/oms/blob/11.16.1/src/Spryker/Zed/Oms/Business/Lock/TriggerLocker.php#L138

Comments

  • Looks like you are right.
    https://github.com/spryker/propel/compare/3.27.0...3.28.0
    propel-orm dependency has been upped, but not the one towards using side.

  • We will fix up master now, and take this into our release backlog. Thank you for the notice.
    These kind of dependency issues are still not easy for us to detect, since we use a monorepo for development, and a prefer-lowest check (existing) here does not find inter-module issues that easily.

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    Options

    Thank you for the feedback! I know the problems 🙂 , we have similar issues with our monorepo for our packages too 🙂