Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi guys, have this problem `Docker Compose version v2.2.1 is not supported. Please update Docker Com

Options
U02U5UPHUC8
U02U5UPHUC8 Posts: 13 🧑🏻‍🚀 - Cadet

Hi guys, have this problem
Docker Compose version v2.2.1 is not supported. Please update Docker Compose to at least 1.22.0.
My Docker Desktop on Windows is up to date.
In settings I tried with disabling and enabling the option Docker Compose V2 and the same error appears.
Yesterday all worked perfectly have someone an idea what could be the problem.

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Docker compose v2 should be disabled in the docker desktop.

  • U02U5UPHUC8
    U02U5UPHUC8 Posts: 13 🧑🏻‍🚀 - Cadet
    Options

    Docker compose V2 is disabled and the error is the same

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    That is really weird. I would try to reboot.

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Or restart Docker Desktop.

  • U02SRQ4HXH8
    U02SRQ4HXH8 Posts: 2 🧑🏻‍🚀 - Cadet
    Options

    Have you run docker/sdk up after disabling the setting in docker?

  • U02U5UPHUC8
    U02U5UPHUC8 Posts: 13 🧑🏻‍🚀 - Cadet
    Options

    I reinstalled the Docker Desktop and now it works fine. Thanks all for your help