Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Spryker updated every newer docker image to composer 2.x which might break some packages

Options
U01N167PSBC
U01N167PSBC Posts: 27 🧑🏻‍🚀 - Cadet

Spryker updated every newer docker image to composer 2.x which might break some packages

Comments

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    Interesting. We've enabled our own Docker images using Composer 2 for quite some time now and at least the "default" Spryker setup works without issue.

  • U01N167PSBC
    U01N167PSBC Posts: 27 🧑🏻‍🚀 - Cadet
    Options

    the default one yes, but you might have packages like hirak/prestissimo to speed up deployments which only work with composer 1

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    prestissimo is not needed for Composer 2 anymore as exactly this feature is now done by composer itself.

  • UPWG9AYH2
    UPWG9AYH2 Posts: 509 🧑🏻‍🚀 - Cadet
    Options

    @UQ958DA4U we had the way around 😄 We had already problems before the announcement today morning … the project could not be installed due to hard dependency of phantomjsinstaller:^2.x in b2b project composer file …

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    We switched to `"jakoch/phantomjs-installer": "^3.0.0",`` for that.

  • UPWG9AYH2
    UPWG9AYH2 Posts: 509 🧑🏻‍🚀 - Cadet
    Options

    Yeah correct … but was not really visible with the composer file of the project

  • UPWG9AYH2
    UPWG9AYH2 Posts: 509 🧑🏻‍🚀 - Cadet
    Options

    Because it still

    “require-dev”: {
    “composer/composer”: “^1.2”,
    “phpunit/phpunit”: “^8”
    },

  • UPWG9AYH2
    UPWG9AYH2 Posts: 509 🧑🏻‍🚀 - Cadet
    edited April 2021
    Options

    I do not assume any compatibility with 2.0 then

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    There could be other compatibility issues with phpstan and other dev modules.
    The possible fix:
    https://sprykercommunity.slack.com/archives/CMYFJCG2E/p1617900162005300?thread_ts=1617869576.000700&cid=CMYFJCG2E