Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Heyhey, if someone has a similar exception like the following one when setting up the dev environmen

Options
fsmeier
fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 ⚖️ - Guardians (admin)

Heyhey,
if someone has a similar exception like the following one when setting up the dev environment (or setting the current one) - We have noticed this and are investigating 🔎

Your lock file does not contain a compatible set of packages. Please run composer update.

  Problem 1
    - Root composer.json requires PHP extension ext-bcmath * but it is missing from your system. Install or enable PHP's bcmath extension.
  Problem 2
    - Root composer.json requires PHP extension ext-gd * but it is missing from your system. Install or enable PHP's gd extension.
  Problem 3
    - Root composer.json requires PHP extension ext-gmp * but it is missing from your system. Install or enable PHP's gmp extension.
  Problem 4
    - Root composer.json requires PHP extension ext-intl * but it is missing from your system. Install or enable PHP's intl extension.
  Problem 5
    - Root composer.json requires PHP extension ext-pdo_pgsql * but it is missing from your system. Install or enable PHP's pdo_pgsql extension.
  Problem 6
    - Root composer.json requires PHP extension ext-pgsql * but it is missing from your system. Install or enable PHP's pgsql extension.
  Problem 7
    - Root composer.json requires PHP extension ext-redis * but it is missing from your system. Install or enable PHP's redis extension.
  Problem 8
    - codeitnowin/barcode is locked to version 3.0.5 and an update of this package was not requested.
    - codeitnowin/barcode 3.0.5 requires ext-gd * -> it is missing from your system. Install or enable PHP's gd extension.
  Problem 9
    - php-amqplib/php-amqplib is locked to version v2.12.3 and an update of this package was not requested.
    - php-amqplib/php-amqplib v2.12.3 requires ext-sockets * -> it is missing from your system. Install or enable PHP's sockets extension.
  Problem 10
    - spryker/decimal-object is locked to version 1.0.1 and an update of this package was not requested.
    - spryker/decimal-object 1.0.1 requires ext-bcmath * -> it is missing from your system. Install or enable PHP's bcmath extension.
  Problem 11
    - php-webdriver/webdriver is locked to version 1.11.1 and an update of this package was not requested.
    - php-webdriver/webdriver 1.11.1 requires ext-zip * -> it is missing from your system. Install or enable PHP's zip extension.
  Problem 12
    - codeitnowin/barcode 3.0.5 requires ext-gd * -> it is missing from your system. Install or enable PHP's gd extension.
    - spryker/code-it-now 1.0.0 requires codeitnowin/barcode ^3.0.0 -> satisfiable by codeitnowin/barcode[3.0.5].
    - spryker/code-it-now is locked to version 1.0.0 and an update of this package was not requested.

Comments

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 ⚖️ - Guardians (admin)
    Options

    Not sure why this happens but the solution is to remove the docker folder and clone again.