Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, I cloned the b2c demo shop according to the installation guide and the docker/sdk version 14.3 (

Options
USPATDHK5
USPATDHK5 Posts: 60 πŸ§‘πŸ»β€πŸš€ - Cadet
edited July 2020 in Docker

Hi,
I cloned the b2c demo shop according to the installation guide and the docker/sdk version 14.3 (I also tried it with version 1.6.3 from the installation guide with the same result) executing docker/sdk up leads to an Aborted install...
I tried pruning the container etc nothing helps 😞
@ULYHPR789 any ideas? πŸ™‚

Comments

  • Thomas Lehner
    Thomas Lehner Support Engineer @ Spryker Posts: 289 πŸ› - Council (mod)
    Options

    what happens if you use the current version of the docker-sdk?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Hello Sarah,

    I am sorry you’ve experienced this behavior.

    The reason is that eventually some NPM packages are not compatible with Alpine 3.11+.

    Change image tag in all deploy.yml files by adding -alpine3.10:
    spryker/php:7.*
    spryker/php:7.*-alpine3.10

    then:
    docker/sdk boot yourfile.yml && docker/sdk up

  • USPATDHK5
    USPATDHK5 Posts: 60 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    nope doesnt like it

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Please, show your changes

  • USPATDHK5
    USPATDHK5 Posts: 60 πŸ§‘πŸ»β€πŸš€ - Cadet
    edited July 2020
    Options
    version: "0.1"
    
    namespace: spryker_b2c_dev_demo
    tag: 'dev'
    
    environment: docker
    image: spryker/php:7.*-alpine3.10
    

    this are the only changes I made to the deploy.dev.yml
    I changed the namespace and the image

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    * should be specific PHP 7. version

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    what was before 7.2 or 7.3?

  • USPATDHK5
    USPATDHK5 Posts: 60 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    7.2

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options
    spryker/php:7.2-alpine3.10
    
  • USPATDHK5
    USPATDHK5 Posts: 60 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    thank you that did the trick πŸ™‚

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Glad to hear!