Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello here o/, I just came across something that I do not understand. or maybe its a bug? We are u

Options
U01FKQ0S909
U01FKQ0S909 Posts: 20 🧑🏻‍🚀 - Cadet

Hello here o/,

I just came across something that I do not understand. or maybe its a bug?

We are using the docker-sdk with the spryker/php:7.4 base image.

The Spryker-Documentation is saying one system requirement is nodejs in version 12. https://documentation.spryker.com/docs/system-requirements
But the docker/sdk is answering that it is using nodejs in version 14. (attached screenshot).

I did a little bit of research and found that:
• node is installed here: https://github.com/spryker/docker-sdk/blob/master/images/common/cli/Dockerfile#L17
• spryker/php is based on: alpine 3.11, 3.12, 3.13 and debian buster https://hub.docker.com/r/spryker/php
• aline 3.13 installs nodejs 14 https://pkgs.alpinelinux.org/packages?name=nodejs&branch=v3.13
is that a known issue? it is an issue?

Comments

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    edited June 2021
    Options

    I assume the requirements mean minimum ones.

    Do you have any issues connected with it? Or is it just justice for consistence? 🙂

  • U01FKQ0S909
    U01FKQ0S909 Posts: 20 🧑🏻‍🚀 - Cadet
    Options

    Hi @ULYHPR789,
    thanks for your response.
    i am not so sure if it is meant to be “minimum nodejs version requirement” because I would
    expect it to be something like >=12 (like the information for databases or redis) ,
    not as documented as Version 12.0.0

    currently we are not having any known issue. The question is just curiosity, for consistency and to avoid future issues 😉

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Thank you for your interest. I agree with you.

    Therefore I am initiating changes/discussion about this inconsistency internally.

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options
  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Viva consistency!