Backend api

bhupendra.doniwal
bhupendra.doniwal Posts: 25 🧑🏻‍🚀 - Cadet

Hi guys, I have cloned 202311.0 b2b marketplace and i was trying to access http://glue-backend.de.spryker.local/
http://backend-api.de.spryker.local/
and i have checked the modules all the modules are there and all the glue related commands are working but my api endpoint is not working the backend api route is showing no route found and the other one is not responding please guide me.

Answers

  • bhupendra.doniwal
    bhupendra.doniwal Posts: 25 🧑🏻‍🚀 - Cadet

    @Alberto Reyer can you please help me out

  • Alberto Reyer
    Alberto Reyer Lead Spryker Solution Architect / Technical Director Posts: 690 🪐 - Explorer

    There should be a docker/sdk cli glue router:cache:warm-up command, did you tried this one to generate the routes?

    If not, you are always free to debug the router, to see why the route is not matched (`\Symfony\Component\HttpKernel\EventListener\RouterListener::onKernelRequest` is the method you want to debug)

  • bhupendra.doniwal
    bhupendra.doniwal Posts: 25 🧑🏻‍🚀 - Cadet

    Instead of the command "docker/sdk cli glue router:cache:warm-up" this "glue api:router:cache:warm-up" command is working and i have debugged and it gives me error and i have tried with host only but having same error is there any plugin which is missing or where i have to place that plugin ?

  • Alberto Reyer
    Alberto Reyer Lead Spryker Solution Architect / Technical Director Posts: 690 🪐 - Explorer

    I assume you followed: https://docs.spryker.com/docs/scos/dev/glue-api-guides/202311.0/routing/create-backend-resources.html especially 3. & 4. are important for the routing. Please double check everything is correctly wired in the GlueBackendApiApplicationDependencyProvider