i try to install the Spryker Code Upgrader but i get an error with package conflicts.
Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires spryker-sdk/upgrader dev-master -> satisfiable by spryker-sdk/upgrader[dev-master].
- spryker-sdk/upgrader dev-master requires symfony/console ^5.0 -> found symfony/console[v5.0.0-BETA1, ..., 5.4.x-dev] but these were not loaded, likely because it conflicts with another require.
You can also try re-running composer require with an explicit version constraint, e.g. "composer require spryker-sdk/upgrader:*" to figure out if any version is installable, or "composer require spryker-sdk/upgrader:^2.1" if you know which you need.
If i try to add the symfony/console at version 5.4.x i get many more conflicts with other packages.
The Spryker Evaluator says that everything is fine.
Has someone an idea how i can fix this problem?
- All Categories
- 38 Getting Started & Guidelines
- 7 Getting Started in the Community
- 8 Additional Resources
- 7 Community Ideas and Feedback
- 33 Spryker News
- 549 Developer Corner
- 420 Spryker Development
- 54 Spryker Dev Environment
- 284 Spryker Releases
- 30 Propel ORM
- 46 Community Projects
- 6 Gacela Project
- 3 PHP Bridge
- 21 Hackathon
- 3.2K 📜 Slack Archives
- 115 Academy
- 5 Business Users
- 370 Docker
- 551 Slack General
- 2K Help
- 75 Knowledge Sharing
- 6 Random
- 4 Code Testing
- 23 Product & Business Questions
- 44 Spryker Safari Questions
- 36 The Blackhole