Calling Developers!
We are reenergizing our code contribution process! Learn More

Spryker Upgrader

Options
rene.kubitzek
rene.kubitzek Spryker Solution Partner Posts: 10 🧑🏻‍🚀 - Cadet

Hi,
i try to install the Spryker Code Upgrader but i get an error with package conflicts.

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires spryker-sdk/upgrader dev-master -> satisfiable by spryker-sdk/upgrader[dev-master].
- spryker-sdk/upgrader dev-master requires symfony/console ^5.0 -> found symfony/console[v5.0.0-BETA1, ..., 5.4.x-dev] but these were not loaded, likely because it conflicts with another require.

You can also try re-running composer require with an explicit version constraint, e.g. "composer require spryker-sdk/upgrader:*" to figure out if any version is installable, or "composer require spryker-sdk/upgrader:^2.1" if you know which you need.

If i try to add the symfony/console at version 5.4.x i get many more conflicts with other packages.

The Spryker Evaluator says that everything is fine.

Has someone an idea how i can fix this problem?

Answers