Calling Developers!
We are reenergizing our code contribution process! Learn More

Tests Failed to connect to 0.0.0.0 port 4444 after 0 ms: Couldn't connect to server

Options
pawel.mlynarczyk
pawel.mlynarczyk Spryker Solution Partner Posts: 7 🧑🏻‍🚀 - Cadet

Hello everyone. I'm trying to run tests for CmsGui, ProductRelation and Tax. Unfortunately, the result for all three is the same:


[Facebook\WebDriver\Exception\Internal\WebDriverCurlException] Curl error thrown for http POST to /session with params: {"capabilities":{"firstMatch":[{"browserName":"chrome"}]},"desiredCapabilities": {"browserName":"chrome"}}

Failed to connect to 0.0.0.0 port 4444 after 0 ms: Couldn't connect to server

My WebDriver is set to Phantomjs by default, which is also installed in one of the docker containers.

This is what codecption.yml looks like for CmsGui:

suites:
Presentation:
path: Presentation
actor: CmsGuiPresentationTester
modules:
enabled:
- \PyzTest\Shared\Testify\Helper\Environment
- \SprykerTest\Shared\Testify\Helper\BrowserHelper
- \SprykerTest\Shared\Application\Helper\ZedHelper
- \SprykerTest\Shared\Config\Helper\ConfigInit
- \SprykerTest\Shared\Testify\Helper\LocatorHelper:
projectNamespaces: ['Pyz'] - \SprykerTest\Shared\Propel\Helper\PropelInstallHelper
- WebDriver:
url: ''
browser: chrome
window_size: 1920x1080
host: 0.0.0.0
port: 4444
restart: false
- \SprykerTest\Shared\Testify\Helper\DataCleanupHelper

Has anyone had a similar problem or have any ideas on how to solve it?

Answers