Calling Developers!
We are reenergizing our code contribution process! Learn More

spryker-shop / b2b-demo-shop / "202307.0" / YVES login issue

s.heinrich
s.heinrich Spryker Solution Partner Posts: 2 🧑🏻‍🚀 - Cadet

Hi there,

not sure if this is the right place, but:

With version "202307.0" of a b2b-demo-shop installation I get an error during YVES login attempt (sonia@spryker.com) on my local machine (normal "docker/sdk" deploy.dev.yml setup on Linux Mint 21.2). Issue is not occuring with previous version "202212.0-p2".

Stack trace excerpt from "spryker.local/logs":

[yves] [yves_eu] - [2023-09-05T09:40:12.873461+00:00] Yves.CRITICAL: Spryker\Shared\ZedRequest\Client\Exception\RequestException - Failed to complete request with server authority http://backend-gateway.de.spryker.local:10011.
Configured with (SSL Disabled) backend-gateway.de.spryker.local:10011 in /data/config/Shared/config_default.php. Error: Stacktrace:
<div style="font-family: Helvetica, Arial, sans-serif; font-size: 14px"><h1>ZED Exception</h1><div style="background: #dadada; padding: 5px"><font style="12"><b>Propel\Runtime\ActiveQuery\QueryExecutor\QueryExecutionException - Unable to execute statement [SELECT spy_store.id_store, spy_store.fk_currency, spy_store.fk_locale, spy_store.name FROM spy_store WHERE spy_store.name=:p1 LIMIT 1]</b></font></div><p>in /data/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/QueryExecutor/AbstractQueryExecutor.php (145)</p><p><b>Url:</b>/customer/gateway/customer</p><p><b>Trace:</b></p><pre>#0 /data/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/QueryExecutor/AbstractQueryExecutor.php(114): Propel\Runtime\ActiveQuery\QueryExecutor\AbstractQueryExecutor->handleStatementException(Object(PDOException), 'SELECT spy_stor...', Object(Propel\Runtime\Connection\StatementWrapper))—

Comparing the "spy_store" table in the database, it looks like some component is expecting some missing columns…

Is anything known about this?

Comments

  • Robson
    Robson Posts: 10 🧑🏻‍🚀 - Cadet

    Try to validate your database setup:

    console propel:schema:validate

  • amansilla
    amansilla Senior Technical Solution Engineer Sprykee Posts: 16 ✨ - Novice
    edited September 2023

    I would say you need to update your database schema. Just run the following command in order to do so:

    console propel:install
    

    Please let us know whether it fixed your issue or not.

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,005 ⚖️ - Guardians (admin)

    Heyhey,
    if the proposed solutions do not work, try the following to clean it up completely:

    rm -Rf vendor
    docker/sdk clean-data
    docker/sdk clean
    docker/sdk bootstrap deploy.dev.yml
    docker/sdk up --build --assets --data
    

    Hope this helps.

    All the best,

    Florian

  • s.heinrich
    s.heinrich Spryker Solution Partner Posts: 2 🧑🏻‍🚀 - Cadet

    Hi guys,

    thanks for your reply.

    I ran "propel:schema:validate" today, which gave me no specific output. So I ran "propel:install", which updated the database schema and the issue was gone :-)

    Strangely I can't reproduce the issue anymore. Setup starting on "docker/sdk prune" and cloning "b2b-demo-shop" 202307.0" branch and so on ... the issue does not return.

    Not sure what's happened or what I did differently (I tried re-setup multiple times) last week.

    Nevertheless, thank you all :-)