Calling Developers!
We are reenergizing our code contribution process! Learn More

How to enable SSL (https) on localhost?

Options
homendrakumar.patle
homendrakumar.patle Spryker Solution Partner Posts: 2 🧑🏻‍🚀 - Cadet

Hi Team,

We have configured the 'adyen' payment method in our local B2B development setup, after configuration backend looks good but in storefront on checkout payment step application is throwing below error. The error is related to SSL disabled. From localhost application is trying to hit payment gateway url with 'https' secured url using curl.

https://checkout-test.adyen.com/v32/paymentMethods

Your help will be appreciated.

Answers

  • domagoj.krizanec
    domagoj.krizanec Spryker Technology Partner Posts: 9 🧑🏻‍🚀 - Cadet
    Options

    Hello.

    In your deploy file for local environment you can enable ssl by setting ssl: enabled flag to true.

    After that you need to boot again this deploy file and run the project.

    Also this needs to be configured in order to work: https://docs.spryker.com/docs/scos/dev/set-up-spryker-locally/configure-after-installing/set-up-a-self-signed-ssl-certificate.html

  • homendrakumar.patle
    homendrakumar.patle Spryker Solution Partner Posts: 2 🧑🏻‍🚀 - Cadet
    Options

    Hi Domagoj,

    Thanks for your help, now I'm able to enabled SSL on my local setup.

    Until Yesterday I was in the assumption that, above mentioned exception is coming due to SSL disabled issue but that was not the case. It is coming because of "host not resolving" issue on local setup with docker.

    Could you please help me again here, how I can fix this error on my local setup. I assume this error must be machine specific. I'm using ubuntu 20.4

    Error:
    GuzzleHttp\Exception\ConnectException - cURL error 6: Could not resolve host: checkout-test.adyen.com

    I have run this url with curl in the cmd and postman and found curl responding correctly whereas with docker setup application is giving the above error.

    I double check all the local setup related host file entries are correct.