What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello , I am trying to install Spryker on AWS and my database is Mysql. in `config/Shared/config_d

Options
U035GSLDLVD
U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet

Hello ,

I am trying to install Spryker on AWS and my database is Mysql.

in config/Shared/config_default.php file, I have defined

$config[PropelConstants::ZED_DB_PORT] = 3306;
$config[PropelConstants::ZED_DB_ENGINE] = $config[PropelConstants::ZED_DB_ENGINE_MYSQL];
$config[PropelQueryBuilderConstants::ZED_DB_ENGINE] = $config[PropelConstants::ZED_DB_ENGINE_MYSQL];

When I run command vendor/bin/install, it throws following errors:
Section database-migrate
Store: DE | Environment: development
Generate diff for Propel2
Propel\Runtime\Connection\Exception\ConnectionException - Exception: Unable to open connection
in /var/www/html/spryker/vendor/propel/propel/src/Propel/Runtime/Connection/ConnectionFactory.php (42)
Command: vendor/bin/console propel:diff
Trace:
#0 /var/www/html/spryker/vendor/propel/pro

Error2:
PHP Notice: Undefined index: ZED_DB_ENGINE_MYSQL in config/Shared/config_default.php on line 272

Comments

  • giovanni.piemontese
    giovanni.piemontese Technical Lead @ Löffelhardt Spryker Solution Partner Posts: 871 🧑🏻‍🚀 - Cadet
    Options

    Maybe so:

    $config[PropelConstants::ZED_DB_PORT] = 3306;
    $config[PropelConstants::ZED_DB_ENGINE] = PropelConfig::DB_ENGINE_MYSQL;
    $config[PropelQueryBuilderConstants::ZED_DB_ENGINE] = PropelConfig::DB_ENGINE_MYSQL;
    
  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    @UL65CH0MC This issue is resolved. Thanks for your help! After successful installation demo data is not showing up on frontend. Jenkins jobs are running perfectly. any command or activity I need to perform?