Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi Can any please guide and help on these error get solve Thank you PHP Fatal error: Declaration o

Options
U03CDV6GDSP
U03CDV6GDSP Posts: 38 🧑🏻‍🚀 - Cadet

Hi
Can any please guide and help on these error get solve
Thank you

PHP Fatal error: Declaration of Orm\Zed\Acl\Persistence\Map\SpyAclGroupArchiveTableMap::initialize() must be compatible with Propel\Runtime\Map\TableMap::initialize(): void in /data/src/Orm/Zed/Acl/Persistence/Map/SpyAclGroupArchiveTableMap.php on line 185
ErrorException - Exception: FATAL ERROR - Declaration of Orm\Zed\Acl\Persistence\Map\SpyAclGroupArchiveTableMap::initialize() must be compatible with Propel\Runtime\Map\TableMap::initialize(): void
in /data/src/Orm/Zed/Acl/Persistence/Map/SpyAclGroupArchiveTableMap.php (185)

Comments

  • Unknown
    edited February 2023
    Options

    You should always mention the tec stack you are using in detail. Otherwise it will be more difficult to give a correct advice/help.
    In this case it is vital to provide info about what exact version of propel is in use, same as spryker modules related to this.

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    edited February 2023
    Options

    I assume that u have updated propel modules and now the auto-generated files in /Orm aren’t compatible with newer interfaces. We solved it by recreating them:

    find src/Orm -type d -name Map -exec rm -rf {} \;
    find src/Orm -type d -name Base -exec rm -rf {} \;
    rm data/cache/propel/generated-conf/loadDatabase.php
    vendor/bin/console propel:model:build
    
  • If this is about beta2, then indeed, the steps are also mentioned on https://api.release.spryker.com/release-group/4239 as well as details linked from there.

  • U03CDV6GDSP
    U03CDV6GDSP Posts: 38 🧑🏻‍🚀 - Cadet
    Options

    Yes, I am updating spryker feature Product Labels,
    I have updated the spryker core version to 202009 (202001 to 202009) and now updating feature Product labels
    I am follwing the Product Labels Feature integration doc available in spryker documentation
    While executing docker up or any command like data:import, shows such error, do
    we need to do any manual changes as spryker/propel is updated

    These are the propel module versions
    propel/propel 2.0.0-beta2
    spryker/propel 3.35.0
    spryker/propel-orm 1.17.0
    spryker/silex 2.2.1

    Thank you

  • U03CDV6GDSP
    U03CDV6GDSP Posts: 38 🧑🏻‍🚀 - Cadet
    Options

    Thank you @UNGMX0012, Thank you @UQK3ZPJEN

    Following these steps of removing the files, and executing propel:model:build, shows the error like

    Spryker\Zed\SynchronizationBehavior\Persistence\Propel\Behavior\Exception\InvalidConfigurationException - Exception: SpyProductLabelDictionaryStorage uses mutually exclusive "store" and "queue_pool" synchronization attributes.
    in /data/vendor/spryker/synchronization-behavior/src/Spryker/Zed/SynchronizationBehavior/Persistence/Propel/Behavior/SynchronizationBehavior.php (531)

    The Synchronization module versions are:
    spryker/synchronization = 1.14.0
    spryker/synchronization-behavior = 1.19.0

    Please find the screenshot of Trace

  • U03CDV6GDSP
    U03CDV6GDSP Posts: 38 🧑🏻‍🚀 - Cadet
    Options

    Hi
    Can any please help on to get the cause of these error and get the resolution
    Thank you

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    edited February 2023
    Options

    u should check the table definition in the related schema file especially the part:

    <behavior name="synchronization">
    
    

    it can either have

    <parameter name="store" required="true"/>
    
    

    or

    <parameter name="queue_pool" value="synchronizationPool"/>
    
    

    not both.

    Afaik spryker added the store synchronization here cause store relation was added and u have to remove the queue_pool

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    Options

    it think it was src/Pyz/Zed/ProductLabelStorage/Persistence/Propel/Schema/spy_product_label_storage.schema.xml 🤔 try to comment that part out

  • U03CDV6GDSP
    U03CDV6GDSP Posts: 38 🧑🏻‍🚀 - Cadet
    Options

    Thank you @UNGMX0012, these fixes helped to resolve the synchronization error
    Thank you so much

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    Options

    nice! you are welcome