Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Good morning, We want to setup a project with the PHP 8.0 alpine docker container from Spryker ```im

Options
USSJ0JX8X
USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
edited December 2021 in Help

Good morning,
We want to setup a project with the PHP 8.0 alpine docker container from Spryker

image:
    tag: spryker/php:8.0-alpine3.13

But we get the following error on frontend:project:install-dependencies

Install Project dependencies
[info] npm
[info]  WARN
[info]  prepare removing existing node_modules/ before installation

[info] 


  core-js@3.4.8 postinstall /data/node_modules/core-js

Does anyone have an idea what we can do to fix this?
The troubleshooting.md doesn't really help in this case.

Comments

  • giovanni.piemontese
    giovanni.piemontese Technical Lead @ Löffelhardt Spryker Solution Partner Posts: 871 🧑🏻‍🚀 - Cadet
    Options

    we use the same image since one month and we don't have any problem regarding frontend installation.... strange...

  • U01T075RRHD
    U01T075RRHD Posts: 118 🧑🏻‍🚀 - Cadet
    Options

    Did you double check the frontend dependencies (they might have changed). I also did that update just recenty without running into that issue.

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    We removed the most modules from the composer.json and in the Pyz folder are only the modules ShopApplication and ShopUI:

    Here the feature list in our composer:

            "spryker-eco/loggly": "^0.1.0",
            "spryker-feature/checkout": "^202108.0",
            "spryker-feature/company-account": "^202108.0",
            "spryker-feature/deployment-tools": "^202108.0",
            "spryker-feature/inventory-management": "202108.0",
            "spryker-feature/navigation": "^202108.0",
            "spryker-feature/product": "^202108.0",
            "spryker-feature/search": "^202108.0",
            "spryker-feature/shipment": "^202108.0",
            "spryker-feature/spryker-core": "^202108.0",
            "spryker-feature/spryker-core-back-office": "^202108.0",
            "spryker/scheduler-jenkins": "^1.2.1",
            "symfony/browser-kit": "^5.1.8",
            "symfony/console": "^5.2.10"
    
  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    I don't think there should be a problem with the dependencies...

  • U01T075RRHD
    U01T075RRHD Posts: 118 🧑🏻‍🚀 - Cadet
    Options

    I'm talking about package.json

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    And we haven't touched the package.json yet

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    Yeah... i just wanted to give you the whole picture

  • U01T075RRHD
    U01T075RRHD Posts: 118 🧑🏻‍🚀 - Cadet
    Options

    You seem to have a frontend dependency that requires Python and that dependency might have been removed/updated/changed in the current version of the Spryker suite

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    We use the current version as basis

  • U01T075RRHD
    U01T075RRHD Posts: 118 🧑🏻‍🚀 - Cadet
    edited December 2021
    Options

    that's odd 🤔

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    that's true

  • UKHR9UN00
    UKHR9UN00 Posts: 70 🧑🏻‍🚀 - Cadet
    Options

    Hi @USSJ0JX8X,
    have you solved this issue and can give some hints?

  • UKHR9UN00
    UKHR9UN00 Posts: 70 🧑🏻‍🚀 - Cadet
    Options

    We solved this issue by explicitly using spryker/php:8.0-alpine3.12 and keeping the package.json up-to-date (according to the b2b demo shop).
    Otherwise there are some pre-compiled binaries missing which would require python to be installed (which was removed from Alpine in v3.12).

  • USSJ0JX8X
    USSJ0JX8X Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    Hi @UKHR9UN00,
    that's also our solution.
    With the image spryker/php:8.0-alpine3.12 the installation of the frontend dependencies is running without a problem.