Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, I am getting Bad Gateway error, Can anyone please suggest

U01AZE27XGV
U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

Hi, I am getting Bad Gateway error, Can anyone please suggest

Comments

  • that looks like a misconfigured nginx or php-fpm in you custom docker environment

  • can you check container health for yves?

  • docker ps

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    yes I can see the details as below

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    Do I need to clear these containers?

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited January 2021

    Is there any local nginx up and running?

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    No @valerii.trots, nothing else is running other then docker.

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    Any suggestions please?

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice

    @ULYHPR789 maybe?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    Please, list the deploy.yml file you use

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    Also run this just after reloading page in browser

    docker logs spryker_b2b_dev_frontend_1
    docker logs spryker_b2b_dev_gateway_1

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    logs from spryker_b2b_dev_frontend_1

  • @U01AZE27XGV, i had to remove your deplo.dev.yml, sorry

  • Unknown
    edited January 2021

    please do not publicly post anything that contains confidential info (secrets, passwords, credentials, etc)

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    okay, sorry for that.

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    I need only groups: part

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet
    groups:
        US:
            region: US
            applications:
                yves_us:
                    application: yves
                    endpoints:
                        yves.us.ricoh.local:
                            store: US
                            services:
                                session:
                                    namespace: 5
                glue_us:
                    application: glue
                    endpoints:
                        glue.us.ricoh.local:
                            store: US
                zed_us:
                    application: zed
                    endpoints:
                        zed.us.ricoh.local:
                            store: US
                            services:
                                session:
                                    namespace: 6
    
  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    Deploy file is ok

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    I do not see 502 error in frontend nginx logs.

    Would you please show logs from gateway and only everything after dumped config. Thanks

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    here are the logs of gateway_1

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    You do not have yves.de.ricoh.local

    In your deploy file it is yves.us.ricoh.local (US one)

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    But it seems you request DE domain

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    okay i will change the host for US and check

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    Now getting site can't be reached error

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    I don't see any errors now

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    but still showing site can't be reached

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    docker/sdk install

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    Do you see white box?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 πŸ§‘πŸ»β€πŸš€ - Cadet

    It is possible you do not have the domain in /etc/hosts

  • U01AZE27XGV
    U01AZE27XGV Posts: 111 πŸ§‘πŸ»β€πŸš€ - Cadet

    it's working, Thank you