Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi people, ```Command yves-build-frontend [vendor/bin/console frontend:yves:build] (In progress...)

Options
UM9F81RCP
UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet

Hi people,

Command yves-build-frontend [vendor/bin/console frontend:yves:build] (In progress...)

This is failing with timeout .. any hints on this? πŸ˜…

Comments

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    which kind of timeout? you tried with -vvv or "npm run yves"?

  • UM9F81RCP
    UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    The process β€œvendor/bin/console frontend:yves:build” exceeded the timeout of 600 seconds.

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Please try to add something like https://github.com/spryker-shop/suite/blob/master/config/install/docker.yml#L78 to the respective command in the install recipe.

  • UM9F81RCP
    UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    when I ran it with -vvv I got this error

    Module not found: Error: Can't resolve 'password-validator' in '/data/vendor/spryker-shop/shop-ui/src/SprykerShop/Yves/ShopUi/Theme/default/components/molecules/password-complexity-indicator'
    
  • UM9F81RCP
    UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    πŸ‘‰πŸ» πŸ‘ˆπŸ» πŸ˜„

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Please note if you have the necessary dependence on password-validator
    https://github.com/spryker-shop/suite/blob/d23d5d9e655cb4b2fdda982d639bccf7801976f0/package.json#L58

  • UM9F81RCP
    UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    I have update core spryker and this started to happen … do you have any idea how is this related?

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    Because of the FE dependencies are on the project level in the root package.json
    So they should be updated as well.

  • UM9F81RCP
    UM9F81RCP Posts: 516 πŸ§‘πŸ»β€πŸš€ - Cadet
    Options

    the upgrade guide does not mention this πŸ˜…