Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi Guys, i need to install local on my docker an extra php extension... `oci8` to allow a connectio

Options
giovanni.piemontese
giovanni.piemontese Technical Lead @ Löffelhardt Spryker Solution Partner Posts: 871 🧑🏻‍🚀 - Cadet

Hi Guys,
i need to install local on my docker an extra php extension... oci8 to allow a connection to an oracle db...

In my deploy.dev.yml file i just modified the image as following:

image:
    tag: spryker/php:7.4
    php:
      enabled-extensions:
        - oci8

Now when i run docker/sdk boostrap deploy.dev.yml command i get the following error:

=> ERROR [11/14] RUN mv /usr/local/etc/php/disabled/oci8.ini /usr/local/etc/php/conf.d/90-oci8.ini                                                                                              0.4s
------                                                                                                                                                                                                


  [11/14] RUN mv /usr/local/etc/php/disabled/oci8.ini /usr/local/etc/php/conf.d/90-oci8.ini:


#17 0.341 mv: cannot stat '/usr/local/etc/php/disabled/oci8.ini': No such file or directory
------
failed to solve with frontend dockerfile.v0: failed to solve with frontend gateway.v0: rpc error: code = Unknown desc = failed to build LLB: executor failed running [/bin/sh -c mv /usr/local/etc/php/disabled/oci8.ini /usr/local/etc/php/conf.d/90-oci8.ini]: runc did not terminate sucessfully

What i did wrong?
Thank u in advance!!!

Comments

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Hello Giovanni,

    enabled-extensions:
    

    This parameter works only with the list of disabled extensions here: https://github.com/spryker/docker-php

    If you want to install an extension you need to extend the entire PHP base image with the extension you need.

    Something like this:

    Place a single Dockerfile, like in the example below.
    
    
    ```Dockerfile
    FROM spryker/php:7.3 as mycustomimage
    
    # Install extensions here
    

    Boot docker/sdk and up, or use on CI/CD.