Calling Developers!
We are reenergizing our code contribution process! Learn More

We have completed the local setup in Ubuntu laptop. But after running the "sudo docker/sdk up" comma

Options
U04N5PQJJDQ
U04N5PQJJDQ Posts: 14 🧑🏻‍🚀 - Cadet
edited June 2023 in Spryker Dev Environment

We have completed the local setup in Ubuntu laptop. But after running the "sudo docker/sdk up" commands, we are receiving the error at the end like "Service search is not running. Please check the name."

Could anyone please help to fix it immediately?

Comments

  • Alberto Reyer
    Alberto Reyer Lead Spryker Solution Architect / Technical Director Posts: 690 🪐 - Explorer
    Options
    1. Why do you run docker/sdk with sudo in front? If that is necessary it looks like your permission setup is wrong
    2. Is there any error log in the search service that might tell you why it won't start (docker logs <containter_id> or docker inspect <container_id>? Often the search service get's killed by the OS/docker because it's taking too much memory. If this is your issue, you can increase the ram memory usage. But by default on ubuntu docker can use all available ram, so it might be either a hardware issue (too less ram available) or other processes on your machine that occupy too much ram. This can be mitigated by increasing your swap file in the OS (https://askubuntu.com/questions/178712/how-to-increase-swap-space)
  • U04N5PQJJDQ
    U04N5PQJJDQ Posts: 14 🧑🏻‍🚀 - Cadet
    Options

    Hi @UL6DGRULR,

    Now I have increased my swap memory to 8GB. But still I can see the same issue. Can you please suggest to fix it?