Calling Developers!
We are reenergizing our code contribution process! Learn More

Hello! We've found a weird issue of project installation failing at scheduler:setup step

Options
U01DE320SN6
U01DE320SN6 Posts: 37 🧑🏻‍🚀 - Cadet

Hello! We've found a weird issue of project installation failing at scheduler:setup step:

Command jenkins-setup [vendor/bin/console scheduler:setup] (In progress...)
Store: DE | Environment: docker.dev
Scheduler Name: jenkins
Scheduler Status: ERROR
Client error: `POST <http://scheduler:8080/createItem?name=DE__amazon-orders-custom-date-range-import>` resulted in a `400 Bad Request` response:


  <!DOCTYPE html><html class=""><head resURL="/static/f28664eb" data-rooturl="" data-resurl="/static/f28664eb" data- (truncated...)

If I do docker/sdk cli and then console scheduler:setup inside the container, the setup will finish correctly, then I can finish the installation, and everything works like a charm:

Store: DE | Environment: docker.dev
Scheduler Name: jenkins
Scheduler Status: OK

Still, confused, why does it fail the first time? Feels like we're experiencing some kind of a race condition within the deploy script.

Tagged:

Comments

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    I had same issue. it's happening when you rename your Jenkins job in jenkins.php file and deploy code. As you changed the name of the job, job with old name will give 404 until you remove that job from the jenkins. It will fail your build with that error message.

    Delete that job and try again, it should work for you.

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    Make sure you have backup of that job in local before deleting it.