Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

With the latest update to spryker/gui 3.49.0 we can't build ZED anymore. `docker/sdk console fronten

Options
UM4BZSK7T
UM4BZSK7T Posts: 174 🧑🏻‍🚀 - Cadet

With the latest update to spryker/gui 3.49.0 we can't build ZED anymore. docker/sdk console frontend:project:install-dependencies -vvv seems to install all dependencies but it still breaks with like 50 missing files during the build process. If I take the dependencies from spryker/gui package.json and merge all those in the package.json on our project root a docker/sdk cli npm run zed will build Zed again. Am I doing something wrong or is this a bug in frontend:project:install-dependencies ?

Comments

  • U019JM2HE7N
    U019JM2HE7N Posts: 61 🧑🏻‍🚀 - Cadet
    Options

    Does your project root package.json contain the required workspace definition?
    https://github.com/spryker-shop/suite/blob/master/package.json#L10
    Also check if your node version matches the engines definition:
    https://github.com/spryker-shop/suite/blob/master/package.json#L38

  • UM4BZSK7T
    UM4BZSK7T Posts: 174 🧑🏻‍🚀 - Cadet
    Options

    Testing all this. Seems our installation is Very Old(tm) ❤

  • UM4BZSK7T
    UM4BZSK7T Posts: 174 🧑🏻‍🚀 - Cadet
    Options

    Seems we are using npm 6 and workspaces start to work from 7...

  • UM4BZSK7T
    UM4BZSK7T Posts: 174 🧑🏻‍🚀 - Cadet
    Options

    Just to note that I have to use the B2B shop version. The suite version of everything is not a not working example.

  • UM4BZSK7T
    UM4BZSK7T Posts: 174 🧑🏻‍🚀 - Cadet
    Options

    Yes our npm version was too old and now the install works if I use the --legacy-peer-deps
    option. Otherwise I get the error below which I don't understand. As I understand it spryker wants angular core from Version ^15.0.3 So the requested version 15.2.2 should be fine. But I am a php programmer and know composer a lot better than npm. Maybe someone can tell me if it's spryker's dependecy hell or something else. 🙂

    npm ERR! ERESOLVE unable to resolve dependency tree
    npm ERR! 
    npm ERR! While resolving: mp-gui-table@0.0.1
    npm ERR! Found: @angular/core@15.1.1
    npm ERR! node_modules/@angular/core
    npm ERR!   peer @angular/core@"^15.0.3" from mp-gui-table@0.0.1
    npm ERR!   vendor/spryker/gui-table
    npm ERR!     mp-gui-table@0.0.1
    npm ERR!     node_modules/mp-gui-table
    npm ERR!       workspace vendor/spryker/gui-table from the root project
    npm ERR!   peer @angular/core@"^15.0.0" from @spryker/table@1.0.1
    npm ERR!   node_modules/@spryker/table
    npm ERR!     @spryker/table@"^1.0.1" from mp-gui-table@0.0.1
    npm ERR!     vendor/spryker/gui-table
    npm ERR!       mp-gui-table@0.0.1
    npm ERR!       node_modules/mp-gui-table
    npm ERR!         workspace vendor/spryker/gui-table from the root project
    npm ERR!   14 more (@angular/cdk, @spryker/actions, @spryker/utils, ...)
    npm ERR! 
    npm ERR! Could not resolve dependency:
    npm ERR! peer @angular/core@"15.2.2" from @angular/elements@15.2.2
    npm ERR! node_modules/@angular/elements
    npm ERR!   peer @angular/elements@"^15.0.0" from @spryker/web-components@1.0.0
    npm ERR!   node_modules/@spryker/web-components
    npm ERR!     peer @spryker/web-components@"^1.0.0" from @spryker/table@1.0.1
    npm ERR!     node_modules/@spryker/table
    npm ERR!       @spryker/table@"^1.0.1" from mp-gui-table@0.0.1
    npm ERR!       vendor/spryker/gui-table