What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello, when trying to install b2b-demo-marketplace, I get the following error: ```Command yves-build

Options
U026LAEAEQZ
U026LAEAEQZ Posts: 6 🧑🏻‍🚀 - Cadet

Hello, when trying to install b2b-demo-marketplace, I get the following error:

Command yves-build-frontend [vendor/bin/console frontend:yves:build] (In progress...)
Store: DE | Environment: docker.dev
Install Merchant Portal dependencies
Output trimmed, only last 100 lines shown.
Store: DE | Environment: docker.dev
Install Zed dependencies
Store: DE | Environment: docker.dev
Build Yves frontend



  spryker-b2b-demo-shop@1.0.0 yves /data

Comments

  • giovanni.piemontese
    giovanni.piemontese Technical Lead @ Löffelhardt Spryker Solution Partner Posts: 871 🧑🏻‍🚀 - Cadet
    Options

    are u sure that in your package.json exists still yves:development:* -- {@} ?
    It was removed since 1 month after IE removing..

  • U026LAEAEQZ
    U026LAEAEQZ Posts: 6 🧑🏻‍🚀 - Cadet
    Options

    Here it is:

  • U019JM2HE7N
    U019JM2HE7N Posts: 61 🧑🏻‍🚀 - Cadet
    Options

    run-s is part of "npm-run-all" which is missing in your "node_modules" -folder. As said in your error log "Local package.json exists, but node_modules missing, did you mean to install?"

    I would recommend to try npm i first, if not even vendor/bin/console frontend:project:install-dependencies

  • U026LAEAEQZ
    U026LAEAEQZ Posts: 6 🧑🏻‍🚀 - Cadet
    Options

    Here's what I got with npm i:

    $ npm i
    npm ERR! code EAI_AGAIN
    npm ERR! errno EAI_AGAIN
    npm ERR! request to <https://registry.npmjs.org/is-docker/-/is-docker-2.2.1.tgz> failed, reason: getaddrinfo EAI_AGAIN [registry.npmjs.org](http://registry.npmjs.org) [registry.npmjs.org:443](http://registry.npmjs.org:443)
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/ihamadet/.npm/_logs/2022-11-16T14_08_46_148Z-debug.log
    
  • U019JM2HE7N
    U019JM2HE7N Posts: 61 🧑🏻‍🚀 - Cadet
    Options

    Sounds like a completely different error. Has very likely something to do with dns or proxy

  • U026LAEAEQZ
    U026LAEAEQZ Posts: 6 🧑🏻‍🚀 - Cadet
    Options

    Ok will try from home when I get there and let you know

  • U026LAEAEQZ
    U026LAEAEQZ Posts: 6 🧑🏻‍🚀 - Cadet
    Options

    Thanks