Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

I am trying to generate access-token for customer through rest api endpoint in my docker based b2b i

Options
U035GSLDLVD
U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet

I am trying to generate access-token for customer through rest api endpoint in my docker based b2b installation.
Header: content-type : application/json
<http://glue.de.spryker.local/>*access-tokens*

{
  "data": {
    "type": "access-tokens",
    "attributes": {
      "username": "<mailto:sonia@spryker.com|sonia@spryker.com>",
      "password": "change123"
    }
  }
}

I am getting 406 not acceptable response. Please help

Comments

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    edited April 2022
    Options

    check the key permission and run glue:rest-request-validation-cache:remove and glue:rest:build-request-validation-cache

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    @UK7KBE2JW Thanks! key permission?

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    Options

    under config/Zed are private and public keys

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    Options
    chmod 600 config/Zed/*_only_*.key
    

    if the pattern for your keys wont fit you have to adjust the statement

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    ok. Those glue commands are not working for me.

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    @UK7KBE2JW Thanks! glues commands doesn't exist. I am using docker b2b solution.

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    Options

    then try with changing permissions, run vendor/bin/console and check the commands under the glue entry. If there is nothing I think you have to register the commands first

  • U035GSLDLVD
    U035GSLDLVD Posts: 90 🧑🏻‍🚀 - Cadet
    Options

    @UK7KBE2JW applying permission fixed the issue. Thanks!

  • UK7KBE2JW
    UK7KBE2JW Posts: 463 🧑🏻‍🚀 - Cadet
    Options

    your welcome