Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, I have the docker spryker setup with docker-sync and the newest Spryker docker/sdk. Since the de

Options
USFC8N1NH
USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet

Hi,
I have the docker spryker setup with docker-sync and the newest Spryker docker/sdk.
Since the debug “-x” flag does not work anymore I have to use the debug cookie.

The Problem:
As soon as the debug session begins the code is frozen, so it is not synced anymore. When I quit the debugging session everything ist fine.
BUT when is start the debug session again the code is again in the state of the first debug session.

It looks like the Spryker debug thing is using a different codebase and is not synchronising my code there. =´(

Comments

  • Unknown
    Options

    @ULYHPR789 do you have any suggestions here?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Hi Fabian,

    What OS do you use?

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    edited July 2020
    Options

    macOS, but a colleague of mine is using windows and has the same issue

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    I know the problem you’ve faced. However it is not reproducible on my side (MacOS). I thought it is Linux issue and CLI only. We have ticket for investigation. I will add that it is not related to OS.

    However I have a workaround for you.

    Change deploy.dev.yml (or copy to deploy.local.yml)

    image:
        tag: spryker/php:7.3
        php:
            ini:
                "opcache.revalidate_freq": 0
                "opcache.enable_cli": 0
                "opcache.enable": 0
    

    run docker/sdk boot deploy.dev.yml && docker/sdk up

    Debugging should work fine. Do not forget to remove that after debugging. 🙂

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    Sadly this does not seem to work =(

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    It seems you have quite different case.

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    Should I write a Bug report?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    I assume that is file sync. If so it is not point to create a bug.

    docker/sdk sync logs - follow if files you changed are synced inside.

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    The Sync process works perfectly. I even checked the files inside the containers.

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    For visualisation purposes here a screen shot where the error occurs in a comment.

    That means the code loaded by the error page is the correct one, but the code that got compiled was not (I think).

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    If opcache is really disabled (please check), there is no other caching mechanism.

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    Can I check it via cli somehow?

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    It looks like the Cache is still enabled :0

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    You lost image:php: look in my example. Sorry, validation is still WIP.

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    Oh I see sry

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    It works :star-struck:

  • USFC8N1NH
    USFC8N1NH Posts: 16 🧑🏻‍🚀 - Cadet
    Options

    Tank you

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    @ULYHPR789 I am experiencing that syncing problem with xdebug on linux. Tried to apply your suggestion to deactivate opcache, but I cannot boot anymore then. It gets stuck at "Building generator...". Any hint?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    edited July 2020
    Options

    No clue, Jochen. Try

    docker/sdk boot -v deploy…

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    nothing

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    bash -x docker/sdk boot deploy…

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    And please list latest several commands when it stuck. Thanks.

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Did it work before?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    It seems generator fails or does not push on host.

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    wait sorry my bad, new shot coming

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    stuck there, does not exit

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    That’s docker issue.
    If you can restart docker deamon and prune - do that.

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    will try later, thanks

  • jochen.gartner
    jochen.gartner Posts: 42 🧑🏻‍🚀 - Cadet
    Options

    i think my vpn connection went crazy and blocked some docker stuff. works now, thank you!

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Glad it is ok now