Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hey Everyone, when I try to install the b2b shop with docker-sdk version 1.22.1 I'm getting this err

Options
U011NH4DY1F
U011NH4DY1F Posts: 19 🧑🏻‍🚀 - Cadet
edited September 2020 in Docker

Hey Everyone, when I try to install the b2b shop with docker-sdk version 1.22.1 I'm getting this error message:

Fatal error: Uncaught Error: Undefined class constant 'RESOLVABLE_CLASS_NAMES_CACHE_ENABLED' in /data/config/Shared/config_default.php:71
Stack trace:
#0 /data/vendor/spryker/config/src/Spryker/Shared/Config/Config.php(189): include()
#1 /data/vendor/spryker/config/src/Spryker/Shared/Config/Config.php(139): Spryker\Shared\Config\Config::buildConfig('default', Object(ArrayObject))
#2 /data/vendor/spryker/config/src/Spryker/Shared/Config/Config.php(57): Spryker\Shared\Config\Config::init()
#3 /data/vendor/spryker/error-handler/src/Spryker/Shared/ErrorHandler/ErrorHandlerEnvironment.php(18): Spryker\Shared\Config\Config::get('ERROR_LEVEL')
#4 /data/vendor/spryker/console/src/Spryker/Zed/Console/Business/Model/Environment.php(34): Spryker\Shared\ErrorHandler\ErrorHandlerEnvironment->__construct()
#5 /data/vendor/spryker/console/src/Spryker/Zed/Console/Communication/ConsoleBootstrap.php(55): Spryker\Zed\Console\Business\Model\Environment::initialize()
#6 /data/vendor/spryker/console/bin/console(20): Spryker\Zed\Console\Communi in /data/config/Shared/config_default.php on line 71

Does anyone know why that happens? This is a clean install with the newest docker version on a macbook

Comments

  • the first line of the error is missing 🤔

  • Unknown
    edited September 2020
    Options

    but this looks like a problem in the code, not with the docker setup.

  • which demoshop version did you start from?

  • U011NH4DY1F
    U011NH4DY1F Posts: 19 🧑🏻‍🚀 - Cadet
    Options

    The tag was: 202001.0-p1

  • U011NH4DY1F
    U011NH4DY1F Posts: 19 🧑🏻‍🚀 - Cadet
    Options

    Added the Full Error message, sorry didn't see a line was missing

  • this is a vanilla demoshop?

  • side question: any reason to not go for the latest version?

  • U011NH4DY1F
    U011NH4DY1F Posts: 19 🧑🏻‍🚀 - Cadet
    Options

    While there is a reason, I also have the new version installed and when I try to docker/sdk up I get the same error message

  • U011NH4DY1F
    U011NH4DY1F Posts: 19 🧑🏻‍🚀 - Cadet
    Options

    I took a look into the config and this is the line:

    $config[KernelConstants::RESOLVABLE_CLASS_NAMES_CACHE_ENABLED] = true;
    
  • ok, i need to investigate a bit here. maybe someone else has inside from the top of theeirs heads?

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    It is not about docker. Kernel version is outdated.

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    Or file sync problem if you use docker-sync/mutagen.

  • Hey @ULYHPR789 did you succeed to resolve the issue? I’ve got a same error right now but on 202009.0