Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi all, I am trying to install Spryker B2B with docker … everything seems to be going well until it

Options
UM9F81RCP
UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet

Hi all,

I am trying to install Spryker B2B with docker … everything seems to be going well until it tries to run installation recipe I get this error …

Any suggestions ? where can I see the logs … because even when I try to read containers logs I don’t seem to find them (or not anything useful)

«1

Comments

  • s.kroll
    s.kroll Head of Technology Spryker @ basecom Posts: 117 ✨ - Novice
    Options

    It seems to be a compatibility problem of the current images and node. Please take a look at the post of Sarah Baumann, a few days ago. It was already discussed there

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    One way you can resolve this is by pulling in the latest versions of both node-sass and @spryker/oryx-for-zed using a docker/sdk cli npm install ... command line. That should do the trick. Otherwise refer to the post by Sarah.

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    i tried to change php image version as mentioned by @ULYHPR789 but now I get a different error (again with npm)

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I think I will try to revert the changes and check your suggestion @UK5EG6PBM

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Wrong Thomas. 😄

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    hehe sorry

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    edited August 2020
    Options

    😅

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I get this error here

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I deleted all the images and containers and restarted and it seems to work now

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I added the hostnamse to the hosts file

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    but I cannot access Yves

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    am I missing something?

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    That makes sense because your setup never started.

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    It aborted in one of the pre-steps.

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    it's also in a broken state right now

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    so to mangle your way through this: docker-compose -f docker/deployment/default/docker-compose.yml up -d

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    after that the docker/sdk cli command I mentioned

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    (npm)

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    then after that - important - docker/sdk reset

  • UQ958DA4U
    UQ958DA4U Posts: 232 🧑🏻‍🚀 - Cadet
    Options

    ah ok. weird.

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    after I deleted all the images and containers I ran boot again and then up

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    which started docker environment

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I can see now all containers that deploy.dev.yaml describes

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    the only issue at the moment I think is that I cannot access the app 😅

  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    Options

    The primal issue was incompatibility with alpine 3.12 and outdated sass npm module

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    I updated php image so now it is

    image: spryker/php:7.2-alpine3.10
    
  • sprymiker
    sprymiker Cloud Platform Architect Sprykee Posts: 781 🧑🏻‍🚀 - Cadet
    edited August 2020
    Options

    So for the history:
    The options are:
    • use apline3.10 image: spryker/php7.3-alpine3.10 (or what PHP version do you use)
    • Upgrade oryx to 2.6.0

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    Installation passed successfully so I assume the original issue is resolved … now the servers are running but I cannot access them

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    oh oh wait

  • UM9F81RCP
    UM9F81RCP Posts: 516 🧑🏻‍🚀 - Cadet
    Options

    i was trying to access with https