Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi everyone, Hi everyone, I am trying to perform Data Transfer O

Options
U045KD44L7L
U045KD44L7L Posts: 55 🧑🏻‍🚀 - Cadet

Hi everyone, Hi everyone, I am trying to perform Data Transfer Object - Hand on

Firstly, I copied the below code in "training.transfer.xml" file
Above file location "src/Pyz/Shared/Training/Transfer/training.transfer.xml"

<?xml version="1.0"?>
" xsi:schemaLocation="spryker:transfer-01 ">

<transfer name="Antelope">
    <property name="idAntelope" type="int"/>
    <property name="name" type="string"/>
</transfer>

Then I execute the command:- docker/sdk console transfer:generate
but I am not getting any auto-generated files in the following path
src/Generated/Shared/Transfer/AntelopeTransfer.php

Nothing is happing, idle it should get generated.

Comments

  • What is the output of the command try to add -v to see the error

  • U04BCHQVACE
    U04BCHQVACE Posts: 39 🧑🏻‍🚀 - Cadet
    Options

    Are you on Windows, Mac or Linux?

  • U045KD44L7L
    U045KD44L7L Posts: 55 🧑🏻‍🚀 - Cadet
    Options

    i am using Ubuntu+Docker in windows

  • U045KD44L7L
    U045KD44L7L Posts: 55 🧑🏻‍🚀 - Cadet
    Options

    As you mentioned I tried -v in the command to see the error below is the screenshot please have a look

  • the first one you run a console command in wrong dir you must run it in your root project
    the second one may you could rebuild your docker but in a dev mode

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,034 ⚖️ - Guardians (admin)
    Options

    In your picture it says that you using an environment in production mode. If you do not use the deploy.dev.yml the file sync is not enabled by default. Best approach would be as Mohammed said: start the environment in dev mode. By docker/sdk bootstrap deploy.dev.yml

  • U045KD44L7L
    U045KD44L7L Posts: 55 🧑🏻‍🚀 - Cadet
    Options

    Hi, Florian as you mentioned I started the environment in Development Mode by using the above command but it gives me an error. I am Attaching the image below

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,034 ⚖️ - Guardians (admin)
    Options

    Seems like a permission problem. saw this several times here in slack but i dont know what was the solution

  • fsmeier
    fsmeier Senior Software Engineer & Developer Enablement Advocate Sprykee Posts: 1,034 ⚖️ - Guardians (admin)
    Options
  • U045KD44L7L
    U045KD44L7L Posts: 55 🧑🏻‍🚀 - Cadet
    Options

    yes it was me, I fix the issue using command: docker/sdk up --build --assets it fix the error in production as you can see