Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello everyone, I seem to have run into the Docker issue above. This seems to have done something w

UQ958DA4U
UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet
edited July 2021 in Docker

Hello everyone,

I seem to have run into the Docker issue above. This seems to have done something with my Mutagen installation that now doesn't want to be reset, even with Compose v1. Any ideas?

☁  project [develop] docker/sdk prune
-->  DEVELOPMENT MODE
Terminating forwarding sessions
Terminating synchronization sessions
stat /var/folders/lw/0zjrrcb110784wjyzts378dm0000gp/T/io.mutagen.compose.3883941212/mutagen.yml: no such file or directory

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice

    So internal guys fixed it in two ways: either rolling back to mutagen 0.12.0-beta2 or via updating macos to big sur.

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    I'm already on Big Sur πŸ˜•

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    Oh hang on... It seems like Docker hasn't taken my Compose downgrade... Will try again.

  • martin
    martin CTO @ VIABIRDS Technologies GmbH Spryker Solution Partner Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    I had this issue too. this was related to the docker compose beta version.

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    Oh yes.. Now that I've actually got Compose v1 again, I run into this error:

    Error: unable to locate requested sessions: specification "<customer>-dev-dev-codebase" did not match any sessions
    

    I've done docker/sdk prune, boot and then up.

    Mutagen is actually empty (I've removed all the sessions) but I don't get why it's not able to create another one?

  • martin
    martin CTO @ VIABIRDS Technologies GmbH Spryker Solution Partner Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    Which mutagen version are you using?

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    0.12.0-beta3

  • martin
    martin CTO @ VIABIRDS Technologies GmbH Spryker Solution Partner Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    This version did not work for me, I had to roll back to 0.12.0-beta2 . But I got a different error when using beta3, so I'm not sure if this might also work for you

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    Hm. I'm sure I reset once since I updated πŸ˜•

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    But I will try this later. Thanks

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet

    Ok everyone, short update. The beta3 wasn't the issue. I think what helped me the most was to reboot the computer, actually.

    Today I made sure that EVERYTHING was clean. No mutagen stuff setup, no docker container, images, volumes and no auto generated Spryker files including docker/sdk deployments.

    After all this, my system is alive again.

  • UQ958DA4U
    UQ958DA4U Posts: 232 πŸ§‘πŸ»β€πŸš€ - Cadet
    edited July 2021

    A few commands for the interested:

    rm -rf vendor src/Generated src/Orm/Propel/Schema public/Yves/assets public/Zed/assets
    docker/sdk clean
    docker/sdk trouble
    mutagen sync list # check empty
    rm -rf docker/deployment/default/
    docker/sdk boot deploy.dev.yml -v
    docker/sdk up -v
    Β