Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi Guys, i have upgraded my spryker project from 202001 to 202009 after upgrading when i am trying t

U04TNUA41LL
U04TNUA41LL Posts: 25 πŸ§‘πŸ»β€πŸš€ - Cadet

Hi Guys, i have upgraded my spryker project from 202001 to 202009 after upgrading when i am trying to run the frontend:yves:build command its throwing me below error, any suggestions on this?

Comments

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    Hi Shivam.
    Check the ShopUi/Theme/default/components/molecules/product-item/product-item.ts component if it’s overridden at the project level.
    The ProductItemData interface must have the sku?: string; property.
    If the component is used from the core, the shop-ui module must be at least version 1.59.0

  • U04TNUA41LL
    U04TNUA41LL Posts: 25 πŸ§‘πŸ»β€πŸš€ - Cadet

    Hi, I checked ShopUi/Theme/default/components/molecules/product-item/product-item.ts its not overridden at the project level. Also i have updated the shop-ui version to 1.59.0 now i am getting below error.

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    I guess there is some confusion with the module version in your project.
    Because the SKU comes to the product-group-widget module here and shouldn’t be in the 202009 release.
    So I see two options:

    • The product-group-widget and shop-ui modules should be downgraded according to the 202009 release.
    • The product-group-widget and shop-ui modules should be updated product-group-widget to 1.9.1 and shop-ui to 1.60.1, but this way new errors may appear due to newer module versions than the release.
  • U04TNUA41LL
    U04TNUA41LL Posts: 25 πŸ§‘πŸ»β€πŸš€ - Cadet

    I don't find product-group-widget in my composer file also its not there in demo shop's composer file still do i need to install this? and from where i can get this?

  • U04TNUA41LL
    U04TNUA41LL Posts: 25 πŸ§‘πŸ»β€πŸš€ - Cadet

    It requires PHP 8 i believe thats why its not there in 202009

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    According to your first screenshot, the project has the module.
    Maybe into some feature.

  • U04TNUA41LL
    U04TNUA41LL Posts: 25 πŸ§‘πŸ»β€πŸš€ - Cadet

    Yes i have but in which feature it is included i don't know so how can i update the version here

  • Yuriy Gerton
    Yuriy Gerton Front End Technical Lead Sprykee Posts: 49 πŸ§‘πŸ»β€πŸš€ - Cadet

    Please try check via

    composer depends spryker-shop/product-group-widget
    

    If it doesn’t help, it’s better to ask one of the BE devs.

  • U04SF37UJQM
    U04SF37UJQM Posts: 7 πŸ§‘πŸ»β€πŸš€ - Cadet

    This command gives "spryker-feature/product-groups 202009.0 requires spryker-shop/product-group-widget (^1.7.0)" in response. I added "spryker-shop/product-group-widget: "^1.9.1" in composer file ran composer update command. Now, it's giving below error