Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Issues with upgrading our Spryker modules (spryker ~2020 - 2022.04)

Options
U01AMEUUMRV
U01AMEUUMRV Posts: 13 🧑🏻‍🚀 - Cadet
edited June 2023 in Help

Hey everyone,
we were upgrading our spryker modules (spryker ~2020 - 2022.04) and right now we are getting the following error message whenever we run composer / reset the system...
Side information we are using this image in our deploy.dev.yml: spryker/php:8.1-debian (my system is a ARM based mac)
Has anyone had a similar problem?
If you need any more specific Information please let me know. 🙂


Stack trace:


Comments

  • Alberto Reyer
    Alberto Reyer Lead Spryker Solution Architect / Technical Director Posts: 690 🪐 - Explorer
    Options

    Did you tried to remove the vendor directory and do a new composer install?

  • U01AMEUUMRV
    U01AMEUUMRV Posts: 13 🧑🏻‍🚀 - Cadet
    Options

    Yes, i did that.
    I also purged all docker-desktop data / images and did a new docker/sdk bootstrap / docker/sdk up.
    That sadly didn't do the trick either. 😞

  • Buenyamin Inan
    Buenyamin Inan Project Tech Lead Sprykee Posts: 8 🧑🏻‍🚀 - Cadet
    edited June 2023
    Options

    This is my first command when I have problem with composer, or ENV. It may be helpful.


  • Buenyamin Inan
    Buenyamin Inan Project Tech Lead Sprykee Posts: 8 🧑🏻‍🚀 - Cadet
    Options

    Do you see this file in the project? It says it does not exist. If you see this file, then your project files are not copied to the container probably.

    vendor/composer/../symfony/polyfill-php80/bootstrap.php
    

    In this case, please check if Mutagen is working:

    mutagen sync list