Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hey Spryks… I’ve hit up against a problem that I hope will be easy to solve. I’ve created a `'Gat

Options
U02P7B6K2LC
U02P7B6K2LC Posts: 121 🧑🏻‍🚀 - Cadet
edited September 2022 in Help

Hey Spryks…

I’ve hit up against a problem that I hope will be easy to solve.

I’ve created a

'GatewayController.php'

file inside my custom module in:

'Pyz/Zed/MyModule/Communication/Controller'

But I get an error that my route is not found.

I’ve tried running:

'router:cache:warm-up'

Then:

'router:cache:warm-up:backend-gateway'

But on checking the generated files… there’s no sign of my custom route in the generated routes file.

It looks like the new GatewayController.php file is not being found by the router.

Is there something I’m missing?

Comments

  • U01K43ADW5N
    U01K43ADW5N Posts: 69 🧑🏻‍🚀 - Cadet
    edited September 2022
    Options

    What are the names of your GatewayController's methods?

    Sometimes I forget to add the Action suffix to the method names and this is exactly what happens.

  • U03C6P70AQY
    U03C6P70AQY Posts: 1 🧑🏻‍🚀 - Cadet
    edited September 2022
    Options

    Firstly, to make sure the URL gateway has register in cache , you need to check in the file: src/Generated/Zed/Router/codeBucketDE/Pyz/UrlMatcher.php codeBucketDE => replace by your store.

  • giovanni.piemontese
    giovanni.piemontese Technical Lead @ Löffelhardt Spryker Solution Partner Posts: 871 🧑🏻‍🚀 - Cadet
    Options

    u have to warm-up the backend-gateway.
    router:cache:warm-up:backend-gateway

  • U02P7B6K2LC
    U02P7B6K2LC Posts: 121 🧑🏻‍🚀 - Cadet
    Options

    @U01K43ADW5N this is EXACTLY this issue! 😄

    I simply added “Action” to my method name and ran the cache warm up and there it was! 🙂

    Thank you!