Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, if anyone successfully integrate Marketplace to a Spryker B2B Shop project? Described in

Options
U044UNCCTDH
U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
edited November 2022 in Help

Hi, if anyone successfully integrate Marketplace to a Spryker B2B Shop project? Described in https://docs.spryker.com/docs/marketplace/dev/feature-integration-guides/202204.0/marketplace-merchant-feature-integration.html
After run composer require spryker-feature/marketplace-merchant:"202204.0" --update-with-dependencies I get error like below when try to run any command like propel:install or data:import

PHP Fatal error: Declaration of Orm\Zed\Acl\Persistence\Map\SpyAclGroupArchiveTableMap::initialize() must be compatible with Propel\Runtime\Map\TableMap::initialize(): void in /data/src/Orm/Zed/Acl/Persistence/Map/SpyAclGroupArchiveTableMap.php on line 185

Fatal error: Declaration of Orm\Zed\Acl\Persistence\Map\SpyAclGroupArchiveTableMap::initialize() must be compatible with Propel\Runtime\Map\TableMap::initialize(): void in /data/src/Orm/Zed/Acl/Persistence/Map/SpyAclGroupArchiveTableMap.php on line 185
ErrorException - Exception: FATAL ERROR - Declaration of Orm\Zed\Acl\Persistence\Map\SpyAclGroupArchiveTableMap::initialize() must be compatible with Propel\Runtime\Map\TableMap::initialize(): void
in /data/src/Orm/Zed/Acl/Persistence/Map/SpyAclGroupArchiveTableMap.php (185)

Comments

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    edited November 2022
    Options

    you solved it? you probably upgraded your propel modules like spryker/propel and spryker/propel-orm so now your auto-generated files in src/Orm are not compatible with new interfaces anymore. you could recursively delete the auto-generated files. I deleted all Map and Base directories:

    find src/Orm -type d -name Map -exec rm -rf {} \;
    find src/Orm -type d -name Base -exec rm -rf {} \;
    

    and re-create them with console propel:install -o
    This worked for me. I also deleted data/cache/propel/generated-conf/loadDatabase.php but not sure if it is necessary.

  • U044UNCCTDH
    U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
    Options

    Hi, yes I made like You say. I found that propel module after upgrade probably is responsible for error. Have You install composer required packages --update-with-dependencies or without this flag? Seems like in this dependencies-upgrade propel is upgraded and then error occurs.

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    Options

    I ran into this while upgrading spryker at all. I am still working on it but usually never use --update-with-dependencies .. at least for now. It would update too many modules in our project.

  • U044UNCCTDH
    U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
    Options

    That same me, thanks for response. Regards

  • U044UNCCTDH
    U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
    Options

    Hi @UNGMX0012, may I have one more question. Have you any issues when install frontend (merchant portal) - many packages missed when run yarn run mp:build, ex: @spryker/actions
    @angular/element etc.

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    Options

    hi @U044UNCCTDH we’re not using this feature. I had the propel problems during upgrade process of propel related modules

  • U044UNCCTDH
    U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
    Options

    Thank You Sebastian

  • U044UNCCTDH
    U044UNCCTDH Posts: 18 🧑🏻‍🚀 - Cadet
    Options

    I guess You are using user roles function in Back Office instead of Merchant Portal to give merchants access?

  • sebastian.larisch
    sebastian.larisch Spryker Customer Posts: 143 🧑🏻‍🚀 - Cadet
    Options

    right