Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

hi, have you already tried new *virtiofs* in the docker for mac? Is it any better than mutagen? Or a

Options
USZB5JN4W
USZB5JN4W Posts: 112 🧑🏻‍🚀 - Cadet

hi,
have you already tried new virtiofs in the docker for mac? Is it any better than mutagen? Or at least as fast as mutagen? I need to upgrade my macos to test it and maybe some of you is already using it 🙂

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    edited April 2022
    Options

    Some internal communication regarding this feature:

    Valerii Trots
    <https://www.docker.com/blog/speed-boost-achievement-unlocked-on-docker-desktop-4-6-for-mac/>
    
    xxx
    It doesn’t look like docker-sdk should support it in any way, there is a new option right in docker. I switched synchronization back to “native” and testing it right now. Will let you know about results
    
    xxx
    It doesn’t work
    Breaks on composer install:
    323/897 [==========>-----------------]  36%    Failed to extract spryker-shop/tabs-widget: (1) '/usr/bin/unzip' -qq '/data/vendor/composer/tmp-d6b6df503e8510ee7cd4eabfbfb2efa9' -d '/data/vendor/composer/cd4cad2b'
    
    warning:  cannot set modif./access times for /data/vendor/composer/cd4cad2b/spryker-shop-tabs-widget-8ce9237/
              Operation not permitted
    warning:  cannot set permissions for /data/vendor/composer/cd4cad2b/spryker-shop-tabs-widget-8ce9237/
              Operation not permitted
    warning:  set times/attribs failed for /data/vendor/composer/cd4cad2b/spryker-shop-tabs-widget-8ce9237/
    
        The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems)
        Unzip with unzip command failed, falling back to ZipArchive class
    
    Without experimental feature all good. So yeah, it’s either docker problem, or some magic inside docker/sdk..
    
    
    
    yyy
    Permission error solved by one of development builds <https://github.com/docker/roadmap/issues/7#issuecomment-1083515882> but project still slower a lot than mutagen
    
    it eats a lot of intel CPU (no antivirus installed)
    
    transfer generate takes 80 sec
    (with mutagen on my pc it takes ~3 sec)
    
  • USZB5JN4W
    USZB5JN4W Posts: 112 🧑🏻‍🚀 - Cadet
    Options

    Thank you @valerii.trots 🙂 So seems like mutagen is still better