Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

I am using the right credentials as mentioned in deploy.dev.yml but not sure its failing to connect.

Options
U0215B7E8T1
U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet

I am using the right credentials as mentioned in deploy.dev.yml but not sure its failing to connect.

Comments

  • U024CDD2S5A
    U024CDD2S5A Posts: 9 🧑🏻‍🚀 - Cadet
    edited June 2021
    Options

    Has you lloked it the db container is running in docker and the password is secret right? Has you use by the bootstrap the deploy.dev.yml when you set up the envoirment?

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    Yes it was running. Looks like I need to run below command
    docker/sdk clean-data && docker/sdk up --data && docker/sdk console q:w:s -v -s

  • U01SE4SRCU9
    U01SE4SRCU9 Posts: 68 🧑🏻‍🚀 - Cadet
    Options

    I don't know about Docker but I had the same issue with Vagrant and there the problem was that due to a port collision, Vagrant forwarded 5432 to some other port. So if Docker provides any details upon launch about port forwarding, check those and see if it maybe had a similar issue and redirected 5432 to some other port. If yes, then enter that port into PHPStorm instead of 5432.

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    looks like running docker/sdk clean-data && docker/sdk up --data && docker/sdk console q:w:s -v -s didnot solve my problem. @valerii.trots @U01AHAH9478 and experts kindly help.

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    please see that it shows spryker user doesnt exist

  • U01SE4SRCU9
    U01SE4SRCU9 Posts: 68 🧑🏻‍🚀 - Cadet
    Options

    Did you check the port issue? In my case, the user not existing was exactly because it was trying to connect to the wrong place (instead of the shop's db) where such a user did not exist indeed.

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    Issue solved. thank you @U01SE4SRCU9

  • U01SE4SRCU9
    U01SE4SRCU9 Posts: 68 🧑🏻‍🚀 - Cadet
    Options

    So it was indeed the port? 🙂 You're welcome, @U0215B7E8T1

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    true it was the port already in use as I was running postgre on native machine.

  • U0215B7E8T1
    U0215B7E8T1 Posts: 31 🧑🏻‍🚀 - Cadet
    Options

    thank you again

  • U01SE4SRCU9
    U01SE4SRCU9 Posts: 68 🧑🏻‍🚀 - Cadet
    Options

    bingo... 👍 yw 🙂