Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hello everybody, I am pretty new to spryker and I am trying to get the spryker b2b_demo_shop workin

Options
U01K8DTPBGA
U01K8DTPBGA Posts: 3 🧑🏻‍🚀 - Cadet

Hello everybody,

I am pretty new to spryker and I am trying to get the spryker b2b_demo_shop working with docker on Ubuntu. I did the steps described in the Spryker docs. The command docker/sdk bootstrap deploy.dev.yml works fine, but when I try to launch the containers using docker/sdk up I am getting following Error:

Error - Exception: Class 'Spryker\Zed\Propel\Business\Model\PropelDatabase\Adapter\MySql\CreateMySqlDatabase' not found
in /data/vendor/spryker/propel/src/Spryker/Zed/Propel/Business/Model/PropelDatabase/Adapter/AdapterFactory.php (60)

Command: vendor/bin/console propel:tables:drop

Trace:

0 /data/vendor/spryker/propel/src/Spryker/Zed/Propel/Business/Model/PropelDatabase/Adapter/AdapterFactory.php(45): Spryker\Zed\Propel\Business\Model\PropelDatabase\Adapter\AdapterFactory->createMySqlCreateCommand()

1 /data/vendor/spryker/propel/src/Spryker/Zed/Propel/Business/PropelBusinessFactory.php(379): Spryker\Zed\Propel\Business\Model\PropelDatabase\Adapter\AdapterFactory->createMySqlAdapter()

2 /data/vendor/spryker/propel/src/Spryker/Zed/Propel/Business/PropelFacade.php(271): Spryker\Zed\Propel\Business\PropelBusinessFactory->createPropelDatabaseAdapterCollection()

3 /data/vendor/spryker/propel/src/Spryker/Zed/Propel/Communication/Console/DatabaseDropTablesConsole.php(46): Spryker\Zed\Propel\Business\PropelFacade->dropDatabaseTables()

4 /data/vendor/symfony/console/Command/Command.php(255): Spryker\Zed\Propel\Communication\Console\DatabaseDropTablesConsole->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

5 /data/vendor/symfony/console/Application.php(1018): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

6 /data/vendor/symfony/console/Application.php(271): Symfony\Component\Console\Application->doRunCommand(Object(Spryker\Zed\Propel\Communication\Console\DatabaseDropTablesConsole), Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

7 /data/vendor/spryker/console/src/Spryker/Zed/Console/Communication/Bootstrap/ConsoleBootstrap.php(110): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

8 /data/vendor/symfony/console/Application.php(147): Spryker\Zed\Console\Communication\Bootstrap\ConsoleBootstrap->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

9 /data/vendor/spryker/console/bin/console(27): Symfony\Component\Console\Application->run()

10

In CommandLineExecutable.php line 107:

Aborted install...

install [-r|--recipe RECIPE] [-d|--dry-run] [-s|--sections SECTIONS] [-g|--groups GROUPS] [-x|--exclude EXCLUDE] [-e|--include-excluded INCLUDE-EXCLUDED] [-i|--interactive] [-b|--breakpoint] [-a|--ask-before-continue] [-l|--log] [--] []

Resuming scheduler... 1s [DONE]

Comments

  • U01JBB8LNTE
    U01JBB8LNTE Posts: 207 🧑🏻‍🚀 - Cadet
    Options

    What ubuntu version ?

    Did you try docker/sdk up --build --assets --data

    Had to do that a few times building on a mac

  • U01K8DTPBGA
    U01K8DTPBGA Posts: 3 🧑🏻‍🚀 - Cadet
    Options

    Hey Edward, thanks for your respond 🙂 I am using Ubuntu 20.04. I tried it several times even with the flags docker/sdk up --build --assets --data and without . But I am getting same error

  • U01JBB8LNTE
    U01JBB8LNTE Posts: 207 🧑🏻‍🚀 - Cadet
    Options

    That is frustrating. 😬 I need to do some setup on my linux I'll see if I get the same error on a fresh install. Didn't have a whole lot of issues on linux yet, but haven't looked at the b2b shop much. Here is a brain dump of commands I've been using on mac

    docker system prune -a && docker system prune --volumes from Valerii

    This ^ is a decently destructive command had to rebuild a few things after I ran it. Sometimes it seems like a container gets corrupted ? ( not sure there ) and the reference is to that container.

    There are quite a few troubleshooting commands in here. I don't see your error, but I've tried running through them one by one to see if they help certain situations.

    https://github.com/spryker/docker-sdk/blob/master/docs/09-troubleshooting.md

    The main ones seem to be

    docker/sdk trouble
    
    docker/sdk reset
    
    docker/sdk trouble && rm -rf vendor && rm -rf src/Generated && docker/sdk sync && docker/sdk up
    

    haven't look at what those are doing under the hood yet, guessing your probably tried most of that stuff already 😄 Hope there's a new one in there.

  • U01K8DTPBGA
    U01K8DTPBGA Posts: 3 🧑🏻‍🚀 - Cadet
    Options

    Hey Edward, thanks for your explanation 🙂 I cloned the project again and deleted all images with docker/sdk clean then i bootstrap the containers using docker/sdk bootstrap deploy.dev.yml and run the contaienrs docker/sdk up it is working perfectly now. I dont know why this error came but now the project is running.

  • U01JBB8LNTE
    U01JBB8LNTE Posts: 207 🧑🏻‍🚀 - Cadet
    Options

    noice 🙌 definitely had to do that several times in the beginning. Glad you got it rolling.