Calling Developers!
We are reenergizing our code contribution process! Learn More

What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi I tried to install docker demo shop in b2c but Elastic Search is Failing: java.lang.IllegalState

Options
U02SWFGE4TH
U02SWFGE4TH Posts: 2 🧑🏻‍🚀 - Cadet
edited January 2022 in Academy

Hi I tried to install docker demo shop in b2c but Elastic Search is Failing:
java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/elasticsearch/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?

Comments

  • Valerii Trots
    Valerii Trots SRE @ Spryker Sprykee Posts: 1,654 ✨ - Novice
    Options

    Hi Jörg! I found couple of occurrences of such a problem in our internal slack and there is no clear\final solution.
    @ULYHPR789 recommended in each case to run clean-data command:

    Mike Kalinin 1 year ago
    docker/sdk clean-data && docker/sdk up
    I assume you have ES data corrupted or created by other version.
    
    
    
    xxx  1 yead ago
    okay, I had a problem with docker network device, but could not remove it because the containers were not halted, and I could not halt the container. SO I restarted my computer, docker up did the same issue, then
    docker/sdk clean-data && docker/sdk up
    worked.
    I'm not sure what the problem was 😞 .
    Thanks !