What are the Slack Archives?

It’s a history of our time together in the Slack Community! There’s a ton of knowledge in here, so feel free to search through the archives for a possible answer to your question.

Because this space is not active, you won’t be able to create a new post or comment here. If you have a question or want to start a discussion about something, head over to our categories and pick one to post in! You can always refer back to a post from Slack Archives if needed; just copy the link to use it as a reference..

Hi, we got a problem installing the demo env on ubuntu. We already installed docker twice and did al

michael.schmetter
michael.schmetter Spryker Solution Partner Posts: 119 🧑🏻‍🚀 - Cadet
edited August 2022 in Docker

Hi,
we got a problem installing the demo env on ubuntu.
We already installed docker twice and did all the prerequistes mentioned here:
https://docs.spryker.com/docs/scos/dev/setup/installing-spryker-with-docker/docker-in[…]-prerequisites/installing-docker-prerequisites-on-linux.html

Nevertheless we get an error at docker/sdk boot genrsa: Can't open "/data/deployment/context/ssh/private.key" for writing, Permission denied%
When running it without sudo.
When running it with sudo, the boot succeeds, but the docker/sdk up fails with:

chmod: changing permissions of '/data/config/Zed/dev_only_private.key': Operation not permitted
chmod: changing permissions of '/data/config/Zed/dev_only_public.key': Operation not permitted
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. It is recommended that you run composer update or composer update <package name>.
Package operations: 959 installs, 0 updates, 0 removals

In Filesystem.php line 268:

  /data/vendor/composer does not exist and could not be created.  


install [--prefer-source] [--prefer-dist] [--prefer-install PREFER-INSTALL] [--dry-run] [--dev] [--no-suggest] [--no-dev] [--no-autoloader] [--no-progress] [--no-install] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--apcu-autoloader-prefix APCU-AUTOLOADER-PREFIX] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--] [<packages>...]

Has anyone an idea, what we could do here?

Comments